Тест 2. Задания с кратким ответом. ОГЭ по информатике

Тест 2. Задания с кратким ответом. ОГЭ по информатике


1) В кодировке КОИ-8 каждый символ кодируется 8 битами. Вова написал текст (в нём нет лишних пробелов):

«Алый, синий, фуксия, красный, янтарный, оранжевый, фиолетовый, канареечный, баклажановый – цвета».

Ученик вычеркнул из списка название одного цвета. Заодно он вычеркнул ставшие лишними запятую и пробел – два пробела не должны идти подряд.

При этом размер нового предложения в данной кодировке оказался на 9 байт меньше, чем размер исходного предложения. Напишите в ответе вычеркнутое название цвета.



2) От разведчика было получено сообщение:

0101011001101010

В этом сообщении зашифрован пароль — последовательность русских букв.

В пароле использовались только буквы А, Б, И, П, Р, Т; каждая буква кодировалась двоичным словом по такой таблице:

АБИПРТ
1000011110010111

Расшифруйте сообщение. Запишите в ответе пароль.



3) Напишите количество натуральных чисел, для которых истинно высказывание:

НЕ (Число > 13) И НЕ (Число чётное).




4) Между населёнными пунктами A, B, C, D, E, F построены дороги, протяжённость которых (в километрах) приведена в таблице.

 ABCDEF
A 3515
B3 14
C51 29
D42 36
E3 2
F1596 2

Определите длину кратчайшего пути между пунктами A и F, проходящего через пункт С. Передвигаться можно только по дорогам, указанным в таблице. Каждый пункт можно посетить только один раз.



5) У исполнителя Алго две команды, которым присвоены номера:

1. прибавь 1

2. умножь на b

(b — неизвестное натуральное число; b ≥ 2).

Выполняя первую из них, Алго увеличивает число на экране на 1, а выполняя вторую, умножает это число на b.

Программа для исполнителя Алго — это последовательность номеров команд.

Известно, что программа 11121 переводит число 5 в число 73.

Определите значение b.



6) Ниже приведена программа, записанная на пяти языках программирования.

Алгоритмический языкПаскаль
алг
нач
  цел  s, k
  ввод s
  ввод k
  если s > 6 и k < 6
    то вывод "YES"
    иначе вывод "NO"
  все
кон
var s, k: integer;
begin
 readln(s);
 readln(k);
 if (s > 6) and (k < 6)
  then
   writeln("YES")
  else
   writeln("NO")
end.
БейсикPython
DIM k, s AS INTEGER
INPUT s
INPUT k
IF s > 6 AND k < 6 THEN
  PRINT "YES"
ELSE
  PRINT "NO"
ENDIF
s = int(input())
k = int(input())
if s > 6 and k < 6:
    print("YES")
else:
    print("NO")
C++
#include <iostream>
using namespace std;
 
int main() {
 int s, k;
 cin >> s;
 cin >> k;
 if (s > 6 && k < 6)
    cout << "YES" << endl;
 else
    cout << "NO" << endl;
 return 0;
}

Было проведено 9 запусков программы, при которых в качестве значений переменных s и k вводились следующие пары чисел:

(1, 1); (7, 0); (8, –12); (6, 6); (3, 11); (–10, –12); (10, 2); (7, 1); (12, 6).

Сколько было запусков, при которых программа напечатала «YES»?



7) Доступ к файлу htm.net, находящемуся на сервере com.edu, осуществляется по протоколу ftp. Фрагменты адреса файла закодированы цифрами от 1 до 7. Запишите последовательность этих цифр, кодирующую адрес указанного файла в сети Интернет.

1) /
2) com
3) .edu
4) ://
5) .net
6) htm
7) ftp



8) В языке запросов поискового сервера для обозначения логической операции «ИЛИ» используется символ «|», а для логической операции «И» – символ «&».

В таблице приведены запросы и количество найденных по ним страниц некоторого сегмента сети Интернет.

ЗапросНайдено страниц (в тысячах)
Москва & Аэропорт1290
Москва1970
Аэропорт2200

Какое количество страниц (в тысячах) будет найдено по запросу Москва | Аэропорт?

Считается, что все запросы выполнялись практически одновременно, так что хранящаяся на поисковом сервере информация о наборе страниц, содержащих все искомые слова, не изменялась за время выполнения запросов.



9) На рисунке — схема дорог, связывающих города А, Б, В, Г, Д, Е, Ж, З, И, К. По каждой дороге можно двигаться только в одном направлении, указанном стрелкой. Сколько существует различных путей из города А в город К, проходящих через город Д?





10) Среди приведённых ниже трёх чисел, записанных в различных системах счисления, найдите максимальное и запишите его в ответе в десятичной системе счисления. В ответе запишите только число, основание системы счисления указывать не нужно.

BF16, 4458, 1011011112




11) Задание выполняется на компьютере.

Архив, необходимый для выполнения задания: ссылка для скачивания.

В одном из произведений Н.В. Гоголя, текст которого приведён в подкаталоге каталога Проза, служанка по имени Мавра приносит главному герою на тарелке угощение. С помощью поисковых средств операционной системы и текстового редактора или браузера выясните, что это было за угощение.



12) Задание выполняется на компьютере.

Архив, необходимый для выполнения задания: ссылка для скачивания.

Сколько файлов с расширением .txt содержится в подкаталогах каталога DEMO-12? В ответе укажите только число.