Тест 22. Задания с кратким ответом. ОГЭ по информатике

Тест 22. Задания с кратким ответом. ОГЭ по информатике


1) В одной из кодировок Unicode каждый символ кодируется 16 битами. Ученик написал текст (в нём нет лишних пробелов):

«Ёж, лев, слон, олень, тюлень, носорог, крокодил, аллигатор – дикие животные».

Ученик удалил из списка название одного животного, а также лишние запятую и пробел – два пробела не должны идти подряд. При этом размер нового предложения в данной кодировке оказался на 16 байт меньше, чем размер исходного предложения. Напишите в ответе удалённое название животного.



2) От разведчика было получено сообщение:

001001110110100

В этом сообщении зашифрован пароль — последовательность русских букв.

В этом сообщении зашифрован пароль – последовательность русских букв. В пароле использовались только буквы А, Б, К, Л, О, С; каждая буква кодировалась двоичным словом по следующей таблице.

АБКЛОС
0110010111100110

Расшифруйте сообщение. Запишите в ответе пароль.



3) Напишите наименьшее натуральное число x, для которого истинно высказывание:

(x > 16) И НЕ (x нечётное).




4) Между населёнными пунктами A, B, C, D, E построены дороги, протяжённость которых (в километрах) приведена в таблице.

 ABCDE
A 14 37
B1 25 
C42 3 
D 353 2
E  2 

Определите длину кратчайшего пути между пунктами A и Е, проходящего через пункт С. Передвигаться можно только по дорогам, протяжённость которых указана в таблице. Каждый пункт можно посетить только один раз.



5) У исполнителя Альфа две команды, которым присвоены номера:

1. прибавь 1

2. умножь на b

(b — неизвестное натуральное число; b ≥ 2).

Первая из них увеличивает число на экране на 1, вторая умножает его на b. Алгоритм для исполнителя Альфа – это последовательность номеров команд. Найдите значение числа b, при котором из числа 6 по алгоритму 11211 будет получено число 82.



6) Ниже приведена программа, записанная на пяти языках программирования.

Алгоритмический языкПаскаль
алг
нач
цел s, t
  ввод s
  ввод t
  если s > 10 или t > 10
    то вывод "YES"
    иначе вывод "NO"
  все
кон
var s, t: integer;
begin
 readln(s);
 readln(t);
 if (s > 10) or (t > 10)
  then
   writeln("YES")
  else
   writeln("NO")
end.
БейсикPython
DIM s, t AS INTEGER
INPUT s
INPUT t
IF s > 10 OR t > 10 THEN
  PRINT "YES"
ELSE
  PRINT "NO"
ENDIF
s = int(input())
t = int(input())
if (s > 10) or (t > 10):
    print("YES")
else:
    print("NO")
C++
#include <iostream>
using namespace std;
 
int main(){
   int s, t;
   cin >> s;
   cin >> t;
   if (s > 10 || t > 10)
     cout << "YES" << endl;
   else
     cout << "NO" << endl;
   return 0;
}

Было проведено 9 запусков программы, при которых в качестве значений переменных вводились следующие пары чисел (s, t):

(1, 2); (11, 2); (1, 12); (11, 12); (–11, –12); (–11, 12); (–12, 11); (10, 10); (10, 5).

Сколько было запусков, при которых программа напечатала «YES»?



7) Доступ к файлу rus.doc, находящемуся на сервере obr.org, осуществляется по протоколу https. Фрагменты адреса файла закодированы цифрами от 1 до 7. Запишите последовательность этих цифр, кодирующую адрес указанного файла в сети Интернет.

1) obr.
2) /
3) org
4) ://
5) doc
6) rus.
7) https



8) В языке запросов поискового сервера для обозначения логической операции «ИЛИ» используется символ «|», а для логической операции «И» – символ «&».

В таблице приведены запросы и количество найденных по ним страниц некоторого сегмента сети Интернет.

ЗапросНайдено страниц (в тысячах)
Рыбак | Рыбка780
Рыбак260
Рыбак & Рыбка50

Какое количество страниц (в тысячах) будет найдено по запросу Рыбка?

Считается, что все запросы выполнялись практически одновременно, так что хранящаяся на поисковом сервере информация о наборе страниц, содержащих все искомые слова, не изменялась за время выполнения запросов.



9) На рисунке – схема дорог, связывающих города А, Б, В, Г, Д, Е, Ж и К. По каждой дороге можно двигаться только в одном направлении, указанном стрелкой. Сколько существует различных путей из города А в город К, проходящих через город В?





10) Среди приведённых ниже трёх чисел, записанных в различных системах счисления, найдите максимальное и запишите его в ответе в десятичной системе счисления. В ответе запишите только число, основание системы счисления указывать не нужно.

2316, 328, 111102




11) Задание выполняется на компьютере.

Архив, необходимый для выполнения задания: ссылка для скачивания.

В одном из произведений А.П. Чехова, текст которого приведён в подкаталоге каталога Проза, героиня произносит такую фразу: «Сегодня я в мерехлюндии, невесело мне, и ты не слушай меня». С помощью поисковых средств операционной системы и текстового редактора или браузера выясните имя этой героини.



12) Задание выполняется на компьютере.

Архив, необходимый для выполнения задания: ссылка для скачивания.

Сколько файлов с расширением .txt содержится в подкаталогах каталога Проза? В ответе укажите только число.