Задание №2755. Ниже приведена программа, записанная на пяти языках программирования. Алгоритмический языкПаскальалг нач цел s, t, A ввод s ввод t ввод A если s > 10 или t > А   то вывод "YES"   иначе вывод "NO" все конvar s, t, A: integer; begin  readln(s);  readln(t);  readln(A);  if (s > 10) or (t > А)   then    writeln("YES")   else    writeln("NO") end.БейсикPythonDIM s, t, A AS INTEGER INPUT s INPUT t INPUT A IF s > 10 OR t > А THEN   PRINT "YES" ELSE   PRINT "NO" ENDIFs = int(input()) t = int(input()) A = int(input()) if (s > 10) or (t > А):     print("YES") else:     print("NO")C++#include <iostream> using namespace std;   int main(){    int s, t, A;    cin >> s;    cin >> t;    cin >> A;    if (s > 10 || t > А)      cout << "YES" << endl;    else      cout << "NO" << endl;    return 0; } Было проведено 9 запусков программы, при которых в качестве значений переменных s и t вводились следующие пары чисел: (1, 2); (11, 2); (1, 12); (11, 12); (–11, –12); (–11, 12); (–12, 11); (10, 10); (10, 5). Укажите наименьшее целое значение параметра А, при котором для указанных входных данных программа напечатает «NO» три раза.


Задание №2755.
Исполнение алгоритмов. ОГЭ по информатике

Ниже приведена программа, записанная на пяти языках программирования.

Алгоритмический языкПаскаль
алг
нач
цел s, t, A
ввод s
ввод t
ввод A
если s > 10 или t > А
  то вывод "YES"
  иначе вывод "NO"
все
кон
var s, t, A: integer;
begin
 readln(s);
 readln(t);
 readln(A);
 if (s > 10) or (t > А)
  then
   writeln("YES")
  else
   writeln("NO")
end.
БейсикPython
DIM s, t, A AS INTEGER
INPUT s
INPUT t
INPUT A
IF s > 10 OR t > А THEN
  PRINT "YES"
ELSE
  PRINT "NO"
ENDIF
s = int(input())
t = int(input())
A = int(input())
if (s > 10) or (t > А):
    print("YES")
else:
    print("NO")
C++
#include <iostream>
using namespace std;
 
int main(){
   int s, t, A;
   cin >> s;
   cin >> t;
   cin >> A;
   if (s > 10 || t > А)
     cout << "YES" << endl;
   else
     cout << "NO" << endl;
   return 0;
}

Было проведено 9 запусков программы, при которых в качестве значений переменных s и t вводились следующие пары чисел:

(1, 2); (11, 2); (1, 12); (11, 12); (–11, –12); (–11, 12); (–12, 11); (10, 10); (10, 5).

Укажите наименьшее целое значение параметра А, при котором для указанных входных данных программа напечатает «NO» три раза.

Пояснение:
Высказывание, написанное в программе, можно переписать в виде:

(s > 10) ИЛИ (t > A).

Чтобы приведенное выше высказывание было ложным, ложными должны быть оба высказывания, так как при дизъюнкции (ИЛИ) новое высказывание является ложным тогда и только тогда, когда оба исходных высказывания ложны.

Заметим, что высказывание (s > 10) будет ложным только при s ≤ 10, поэтому оставим пары переменных чисел s и t, удовлетворяющих данному условию:

(1, 2); (1, 12); (–11, –12); (–11, 12); (–12, 11); (10, 10); (10, 5).

Теперь нам необходимо подобрать наименьшее значение параметра А, при котором высказывание (t > A) будет ложным три раза (при t = 2; 12; –12; 12; 11; 10; 5).

Подставим вместо А число 5: (t > 5).

Тогда при t = 2 получим: (2 > 5) — ложь; при t = 12 получим: (12 > 5) — истина; при t = –12 получим: (–12 > 5) — ложь; при t = 12 получим: (12 > 5) — истина; при t = 11 получим: (11 > 5) — истина; при t = 10 получим: (10 > 5) — истина; при t = 5 получим: (5 > 5) — ложь.

Отметим, что при А = 6; 7; 8; 9 высказывание (t > A) будет также ложным три раза, однако по условию задания нам необходимо подобрать наименьшее целое значение параметра А.

Таким образом, 5 — наименьшее целое значение параметра А, при котором для указанных входных данных программа напечатает «NO» три раза.

Показать ответ

Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке


Тест с похожими заданиями