Задание №2758.
Исполнение алгоритмов. ОГЭ по информатике
Ниже приведена программа, записанная на пяти языках программирования.
| Алгоритмический язык | Паскаль |
алг нач цел s, t, A ввод s ввод t ввод A если s > А или t > 11 то вывод "YES" иначе вывод "NO" все кон | var s, t, A: integer; begin readln(s); readln(t); readln(A); if (s > А) or (t > 11) then writeln("YES") else writeln("NO") end. |
| Бейсик | Python |
DIM s, t, A AS INTEGER INPUT s INPUT t INPUT A IF s > А OR t > 11 THEN PRINT "YES" ELSE PRINT "NO" ENDIF | s = int(input()) t = int(input()) A = int(input()) if (s > А) or (t > 11): print("YES") else: print("NO") |
| C++ |
#include <iostream> using namespace std; int main(){ int s, t, A; cin >> s; cin >> t; cin >> A; if (s > А || t > 11) cout << "YES" << endl; else cout << "NO" << endl; return 0; } |
Было проведено 9 запусков программы, при которых в качестве значений переменных s и t вводились следующие пары чисел:
(–9, 11); (2, 7); (5, 12); (2, –2); (7, –9); (12, 6); (9, –1); (7, 11); (11, –5).
Укажите наибольшее целое значение параметра А, при котором для указанных входных данных программа напечатает «YES» три раза.
Пояснение:
Высказывание, написанное в программе, можно переписать в виде:
(s > A) ИЛИ (t > 11).Чтобы приведенное выше высказывание было истинным, истинным должно быть хотя бы одно из исходных высказываний, так как при дизъюнкции (ИЛИ) новое высказывание является ложным тогда и только тогда, когда оба исходных высказывания ложны.
Заметим, что высказывание (
t > 11) будет истинным при
t ≥ 12. Следовательно, при подстановке пары чисел (5, 12) высказывание
(s > A) ИЛИ (t > 11)будет истинным вне зависимости от значения параметра
A.
Поэтому наша задача сводится к поиску наибольшего целого значения параметра
А, при котором высказывание (
s >
A) будет истинным два раза при значениях переменной
s из оставшихся восьми пар чисел (при
s = –9; 2; 2; 7; 12; 9; 7; 11).
Подставим вместо
А число 10: (
s > 10).
Тогда при
s = –9 получим: (–9 > 10) — ложь; при
s = 2 получим: (2 > 10) — ложь; при
s = 2 получим: (2 > 10) — ложь; при
s = 7 получим: (7 > 10) — ложь; при
s = 12 получим: (12 > 10) —
истина; при
s = 9 получим: (9 > 10) — ложь; при
s = 7 получим: (7 > 10) — ложь; при
s = 11 получим: (11 > 10) —
истина.
Отметим, что при
А = 9 высказывание (
s >
A) будет также истинным два раза, однако по условию задания нам необходимо подобрать
наибольшее целое значение параметра
А.
Таким образом,
10 — наибольшее целое значение параметра А, при котором для указанных входных данных программа напечатает «YES» три раза.
Показать ответ
10
Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке
Тест с похожими заданиями