Задание №2840. Задание выполняется на компьютере. Результатом выполнения задания является отдельный файл. Выберите ОДНО из предложенных ниже заданий: 15.1 или 15.2. 15.1 Исполнитель Робот умеет перемещаться по лабиринту, начерченному на плоскости, разбитой на клетки. Между соседними (по сторонам) клетками может стоять стена, через которую Робот пройти не может. У Робота есть девять команд. Четыре команды – это команды-приказы: вверх вниз влево вправо При выполнении любой из этих команд Робот перемещается на одну клетку соответственно: вверх ↑, вниз ↓, влево ←, вправо →. Если Робот получит команду передвижения сквозь стену, то он разрушится. Также у Робота есть команда закрасить, при которой закрашивается клетка, в которой Робот находится в настоящий момент. Ещё четыре команды – это команды проверки условий. Эти команды проверяют, свободен ли путь для Робота в каждом из четырёх возможных направлений: сверху свободно снизу свободно слева свободно справа свободно Эти команды можно использовать вместе с условием «eсли», имеющим следующий вид: если условие то последовательность команд все Здесь условие – одна из команд проверки условия. Последовательность команд – это одна или несколько любых команд-приказов. Например, для передвижения на одну клетку вправо, если справа нет стенки и закрашивания клетки, можно использовать такой алгоритм: если справа свободно то   вправо   закрасить все В одном условии можно использовать несколько команд проверки условий, применяя логические связки и, или, не, например: если (справа свободно) и (не снизу свободно) то   вправо все Для повторения последовательности команд можно использовать цикл «пока», имеющий следующий вид: нц пока условие   последовательность команд кц Например, для движения вправо, пока это возможно, можно использовать следующий алгоритм: нц пока справа свободно   вправо кц Выполните задание. На бесконечном поле имеется лестница. Высота подъема лестницы неизвестна. Сначала лестница поднимается вверх, затем спускается вниз. Высота спуска также неизвестна. Высота и ширина каждой ступени – одна клетка. Робот находится под нижней ступенькой у левого края лестницы. На рисунке указан один из возможных способов расположения лестницы и Робота. Робот обозначен буквой «Р». Напишите для Робота алгоритм, закрашивающий все клетки, расположенные под ступенями лестницы. Требуется закрасить только клетки, удовлетворяющие данному условию. Например, для приведённого выше рисунка Робот должен закрасить следующие клетки (см. рисунок). Конечное расположение Робота может быть произвольным. Алгоритм должен решать задачу для произвольного размера поля и любого допустимого расположения лестницы. При исполнении алгоритма Робот не должен разрушиться. Алгоритм может быть выполнен в среде формального исполнителя или записан в текстовом редакторе. Название файла и каталог для сохранения Вам сообщат организаторы экзамена. 15.2 Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, оканчивающихся на 6. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, оканчивающееся на 6. Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число – количество чисел, оканчивающихся на 6. Пример работы программы: Входные данныеВыходные данные3 16 26 242

Задание №2840.
Создание программы для заданного исполнителя или на универсальном языке программирования. ОГЭ по информатике

Задание выполняется на компьютере. Результатом выполнения задания является отдельный файл.

Выберите ОДНО из предложенных ниже заданий: 15.1 или 15.2.

15.1 Исполнитель Робот умеет перемещаться по лабиринту, начерченному на плоскости, разбитой на клетки. Между соседними (по сторонам) клетками может стоять стена, через которую Робот пройти не может.

У Робота есть девять команд. Четыре команды – это команды-приказы:

вверх вниз влево вправо

При выполнении любой из этих команд Робот перемещается на одну клетку соответственно: вверх ↑, вниз ↓, влево ←, вправо →. Если Робот получит команду передвижения сквозь стену, то он разрушится.

Также у Робота есть команда закрасить, при которой закрашивается клетка, в которой Робот находится в настоящий момент.

Ещё четыре команды – это команды проверки условий. Эти команды проверяют, свободен ли путь для Робота в каждом из четырёх возможных направлений:

сверху свободно

снизу свободно

слева свободно

справа свободно

Эти команды можно использовать вместе с условием «eсли», имеющим следующий вид:

если условие то

последовательность команд

все

Здесь условие – одна из команд проверки условия.

Последовательность команд – это одна или несколько любых команд-приказов.

Например, для передвижения на одну клетку вправо, если справа нет стенки и закрашивания клетки, можно использовать такой алгоритм:

если справа свободно то

  вправо

  закрасить

все

В одном условии можно использовать несколько команд проверки условий, применяя логические связки и, или, не, например:

если (справа свободно) и (не снизу свободно) то

  вправо

все

Для повторения последовательности команд можно использовать цикл «пока», имеющий следующий вид:

нц пока условие

  последовательность команд

кц

Например, для движения вправо, пока это возможно, можно использовать следующий алгоритм:

нц пока справа свободно

  вправо

кц

Выполните задание.

На бесконечном поле имеется лестница. Высота подъема лестницы неизвестна. Сначала лестница поднимается вверх, затем спускается вниз. Высота спуска также неизвестна. Высота и ширина каждой ступени – одна клетка. Робот находится под нижней ступенькой у левого края лестницы.

На рисунке указан один из возможных способов расположения лестницы и Робота. Робот обозначен буквой «Р».


Напишите для Робота алгоритм, закрашивающий все клетки, расположенные под ступенями лестницы. Требуется закрасить только клетки, удовлетворяющие данному условию. Например, для приведённого выше рисунка Робот должен закрасить следующие клетки (см. рисунок).


Конечное расположение Робота может быть произвольным. Алгоритм должен решать задачу для произвольного размера поля и любого допустимого расположения лестницы. При исполнении алгоритма Робот не должен разрушиться.

Алгоритм может быть выполнен в среде формального исполнителя или записан в текстовом редакторе.

Название файла и каталог для сохранения Вам сообщат организаторы экзамена.

15.2 Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, оканчивающихся на 6. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, оканчивающееся на 6.

Количество чисел не превышает 1000. Введённые числа не превышают 30 000.

Программа должна вывести одно число – количество чисел, оканчивающихся на 6.

Пример работы программы:

Входные данныеВыходные данные
3
16
26
24
2


Пояснение:
15.1 Пример верного алгоритма:

алг
нач
влево
вниз
вправо
нц пока справа свободно
      закрасить
      вправо
      вверх
кц
нц пока не справа свободно
      закрасить
      вниз
      вправо
кц
закрасить
кон


15.2 Решением является программа, записанная на любом языке программирования. Пример верного решения, записанного на языке Python:

total_numbers = int(input())

count_numbers_ending_in_six = 0

for number in range(total_numbers):
    number = str(input())
    if number[-1] == '6':
        count_numbers_ending_in_six += 1
print(count_numbers_ending_in_six)


Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке


Тест с похожими заданиями