Задание №2841. Задание выполняется на компьютере. Результатом выполнения задания является отдельный файл. Выберите ОДНО из предложенных ниже заданий: 15.1 или 15.2. 15.1 Исполнитель Робот умеет перемещаться по лабиринту, начерченному на плоскости, разбитой на клетки. Ниже приведено описание Робота. У Робота есть четыре команды перемещения: вверх вниз влево вправо При выполнении любой из этих команд Робот перемещается на одну клетку соответственно: вверх ↑, вниз ↓, влево ←, вправо →. Между соседними (по сторонам) клетками может стоять стена, через которую Робот пройти не может. Если Робот получит команду передвижения через стену, то он разрушится. Четыре команды проверяют истинность условия отсутствия стены у каждой стороны той клетки, где находится Робот: сверху свободно снизу свободно слева свободно справа свободно Эти команды можно использовать вместе с условием «eсли», имеющим следующий вид: если условие то последовательность команд все «Последовательность команд» – это одна или несколько любых команд, выполняемых Роботом. Например, для передвижения на одну клетку вправо, если справа нет стенки, можно использовать такой алгоритм: если справа свободно то   вправо все В одном условии можно использовать несколько команд проверки условий, применяя логические связки и, или, не, например: если (справа свободно) и не (снизу свободно) то   вправо все Для повторения последовательности команд можно использовать цикл «пока», имеющий следующий вид: нц пока условие   последовательность команд кц Например, для движения вправо, пока это возможно, можно использовать следующий алгоритм: нц пока справа свободно   вправо кц Также у Робота есть команда закрасить, закрашивающая клетку, в которой Робот находится в настоящий момент. Выполните задание. На бесконечном поле имеется лестница. Сначала лестница спускается вниз слева направо, потом поднимается вверх также слева направо. После подъема лестница переходит в вертикальную стену. Высота каждой ступени 1 клетка, ширина – 1 клетка. Количество ступенек, ведущих вверх, и количество ступенек, ведущих вниз, неизвестно. Между спуском и подъемом ширина площадки 1 клетка. Робот находится в клетке, расположенной в начале спуска. На рисунке указан один из возможных способов расположения стен и Робота (Робот обозначен буквой «Р»). Напишите для Робота алгоритм, закрашивающий все клетки, расположенные непосредственно над лестницей, как показано на рисунке. Робот должен закрасить только клетки, удовлетворяющие данному условию. Например, для приведённого выше рисунка Робот должен закрасить следующие клетки (см. рисунок). Конечное расположение Робота может быть произвольным. Алгоритм должен решать задачу для бесконечного поля и любого количества ступеней. При исполнении алгоритма Робот не должен разрушиться. 15.2 Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, кратных 6 и оканчивающихся на 2. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 6 и оканчивающееся на 2. Количество чисел не превышает 100. Введённые числа по модулю не превышают 300. Программа должна вывести одно число: сумму чисел, кратных 6 и оканчивающихся на 2. Пример работы программы: Входные данныеВыходные данные3 12 25 4254

Задание №2841.
Создание программы для заданного исполнителя или на универсальном языке программирования. ОГЭ по информатике

Задание выполняется на компьютере. Результатом выполнения задания является отдельный файл.

Выберите ОДНО из предложенных ниже заданий: 15.1 или 15.2.

15.1 Исполнитель Робот умеет перемещаться по лабиринту, начерченному на плоскости, разбитой на клетки. Ниже приведено описание Робота. У Робота есть четыре команды перемещения:

вверх вниз влево вправо

При выполнении любой из этих команд Робот перемещается на одну клетку

соответственно: вверх ↑, вниз ↓, влево ←, вправо →.

Между соседними (по сторонам) клетками может стоять стена, через которую Робот пройти не может. Если Робот получит команду передвижения через стену, то он разрушится.

Четыре команды проверяют истинность условия отсутствия стены у каждой стороны той клетки, где находится Робот:

сверху свободно

снизу свободно

слева свободно

справа свободно

Эти команды можно использовать вместе с условием «eсли», имеющим следующий вид:

если условие то

последовательность команд

все

«Последовательность команд» – это одна или несколько любых команд, выполняемых Роботом. Например, для передвижения на одну клетку вправо, если справа нет стенки, можно использовать такой алгоритм:

если справа свободно то

  вправо

все

В одном условии можно использовать несколько команд проверки условий,

применяя логические связки и, или, не, например:

если (справа свободно) и не (снизу свободно) то

  вправо

все

Для повторения последовательности команд можно использовать цикл «пока», имеющий следующий вид:

нц пока условие

  последовательность команд

кц

Например, для движения вправо, пока это возможно, можно использовать следующий алгоритм:

нц пока справа свободно

  вправо

кц

Также у Робота есть команда закрасить, закрашивающая клетку, в которой Робот находится в настоящий момент.

Выполните задание.

На бесконечном поле имеется лестница. Сначала лестница спускается вниз слева направо, потом поднимается вверх также слева направо. После подъема лестница переходит в вертикальную стену. Высота каждой ступени 1 клетка, ширина – 1 клетка. Количество ступенек, ведущих вверх, и количество ступенек, ведущих вниз, неизвестно. Между спуском и подъемом ширина площадки 1 клетка.

Робот находится в клетке, расположенной в начале спуска.

На рисунке указан один из возможных способов расположения стен и Робота (Робот обозначен буквой «Р»).


Напишите для Робота алгоритм, закрашивающий все клетки, расположенные непосредственно над лестницей, как показано на рисунке. Робот должен закрасить только клетки, удовлетворяющие данному условию. Например, для приведённого выше рисунка Робот должен закрасить следующие клетки (см. рисунок).


Конечное расположение Робота может быть произвольным. Алгоритм должен решать задачу для бесконечного поля и любого количества ступеней. При исполнении алгоритма Робот не должен разрушиться.

15.2 Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, кратных 6 и оканчивающихся на 2. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 6 и оканчивающееся на 2.

Количество чисел не превышает 100. Введённые числа по модулю не превышают 300.

Программа должна вывести одно число: сумму чисел, кратных 6 и оканчивающихся на 2.

Пример работы программы:

Входные данныеВыходные данные
3
12
25
42
54


Пояснение:
15.1 Пример верного алгоритма:

алг
нач
вправо
вниз
нц пока справа свободно
      закрасить
      вправо
      закрасить
      вниз
кц
закрасить
вверх
нц пока справа свободно
      закрасить
      вправо
      закрасить
      вверх
кц
кон


15.2 Решением является программа, записанная на любом языке программирования. Пример верного решения, записанного на языке Python:

total_numbers = int(input())

sum_of_numbers = 0

for number in range(total_numbers):
    number = int(input())
    if number % 6 == 0 and str(number)[-1] == "2":
        sum_of_numbers += number
print(sum_of_numbers)


Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке


Тест с похожими заданиями