Задание №3425. Задание выполняется на компьютере. Архив, необходимый для выполнения задания: ссылка для скачивания. Сколько файлов c расширением htm, каждый объёмом от 140 Кб до 600 Кб включительно, содержится в подкаталогах каталога DEMO-12? В ответе укажите только число.

Задание №3425.
Определение количества и размера файлов, отобранных по некоторому условию. ОГЭ по информатике

Задание выполняется на компьютере.

Архив, необходимый для выполнения задания: ссылка для скачивания.

Сколько файлов c расширением htm, каждый объёмом от 140 Кб до 600 Кб включительно, содержится в подкаталогах каталога DEMO-12? В ответе укажите только число.

Пояснение:
6 — столько файлов c расширением htm, каждый объёмом от 140 Кб до 600 Кб включительно, содержится в подкаталогах каталога DEMO-12.

Python-код для перебора файлов в каталоге:

import os

rootdir = r'' # Переменная для указания пути к каталогу; например, r'C:\Users\DEMO-12'

for subdir, dirs, files in os.walk(rootdir):
    for file in files:
        file_path = subdir + os.sep + file
        file_size = os.path.getsize(file_path) # размер файла в байтах
        print(f"{file_path} (размер: {file_size} байт)")


Показать ответ

Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке


Тест с похожими заданиями