Задание №3690. Ниже приведена программа, записанная на пяти языках программирования. Алгоритмический языкПаскальалг нач цел s, t, A ввод s ввод t ввод A если s > А или t > 11   то вывод "YES"   иначе вывод "NO" все конvar s, t, A: integer; begin  readln(s);  readln(t);  readln(A);  if (s > А) or (t > 11)   then    writeln("YES")   else    writeln("NO") end.БейсикPythonDIM s, t, A AS INTEGER INPUT s INPUT t INPUT A IF s > А OR t > 11 THEN   PRINT "YES" ELSE   PRINT "NO" ENDIFs = int(input()) t = int(input()) A = int(input()) if (s > А) or (t > 11):     print("YES") else:     print("NO")C++#include <iostream> using namespace std;   int main(){    int s, t, A;    cin >> s;    cin >> t;    cin >> A;    if (s > А || t > 11)      cout << "YES" << endl;    else      cout << "NO" << endl;    return 0; } Было проведено 9 запусков программы, при которых в качестве значений переменных s и t вводились следующие пары чисел: (–9, 11); (2, 7); (5, 12); (2, –2); (7, –9); (12, 6); (9, –1); (7, 11); (11, –5). Укажите наибольшее целое значение параметра А, при котором для указанных входных данных программа напечатает «YES» шесть раз.


Задание №3690.
Исполнение алгоритмов. ОГЭ по информатике

Ниже приведена программа, записанная на пяти языках программирования.

Алгоритмический языкПаскаль
алг
нач
цел s, t, A
ввод s
ввод t
ввод A
если s > А или t > 11
  то вывод "YES"
  иначе вывод "NO"
все
кон
var s, t, A: integer;
begin
 readln(s);
 readln(t);
 readln(A);
 if (s > А) or (t > 11)
  then
   writeln("YES")
  else
   writeln("NO")
end.
БейсикPython
DIM s, t, A AS INTEGER
INPUT s
INPUT t
INPUT A
IF s > А OR t > 11 THEN
  PRINT "YES"
ELSE
  PRINT "NO"
ENDIF
s = int(input())
t = int(input())
A = int(input())
if (s > А) or (t > 11):
    print("YES")
else:
    print("NO")
C++
#include <iostream>
using namespace std;
 
int main(){
   int s, t, A;
   cin >> s;
   cin >> t;
   cin >> A;
   if (s > А || t > 11)
     cout << "YES" << endl;
   else
     cout << "NO" << endl;
   return 0;
}

Было проведено 9 запусков программы, при которых в качестве значений переменных s и t вводились следующие пары чисел:

(–9, 11); (2, 7); (5, 12); (2, –2); (7, –9); (12, 6); (9, –1); (7, 11); (11, –5).

Укажите наибольшее целое значение параметра А, при котором для указанных входных данных программа напечатает «YES» шесть раз.

Пояснение:
6 — наибольшее целое значение параметра А, при котором для указанных входных данных программа напечатает «YES» шесть раз.

Показать ответ

Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке


Тест с похожими заданиями