Задание №3894. Задание выполняется на компьютере. Результатом выполнения задания является отдельный файл. Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, оканчивающихся на 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, оканчивающееся на 4. Количество чисел не превышает 100. Введённые числа не превышают 300. Программа должна вывести одно число – сумму чисел, оканчивающихся на 4. Пример работы программы: Входные данныеВыходные данные3 14 25 2438

Задание №3894.
Создание программы. ОГЭ по информатике

Задание выполняется на компьютере. Результатом выполнения задания является отдельный файл.

Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, оканчивающихся на 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, оканчивающееся на 4.

Количество чисел не превышает 100. Введённые числа не превышают 300.

Программа должна вывести одно число – сумму чисел, оканчивающихся на 4.

Пример работы программы:

Входные данныеВыходные данные
3
14
25
24
38


Пояснение:
Решением является программа, записанная на любом языке программирования. Пример верного решения, записанного на языке Python:

total_numbers = int(input())

sum_of_numbers = 0

for __ in range(total_numbers):
    number = int(input())
    if str(number)[-1] == '4':
        sum_of_numbers += number
print(sum_of_numbers)


Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке


Тест с похожими заданиями