Задание №3900. Задание выполняется на компьютере. Результатом выполнения задания является отдельный файл. Напишите программу для решения следующей задачи. На зачётной работе по физике ученикам 9 класса было предложено 12 задач. Зачёт можно получить, если правильно решить не менее 8 задач. Сколько учеников получило зачёт? Вычислите среднее количество правильно решённых задач учащимися, получившими зачёт. Гарантируется, что хотя бы один ученик сдал зачёт. Программа получает на вход количество учеников в классе N (1 ≤ N ≤ 30), затем для каждого ученика вводится количество правильно решённых задач. Пример работы программы: Входные данныеВыходные данные4 3 9 10 62 9.5

Задание №3900.
Создание программы. ОГЭ по информатике

Задание выполняется на компьютере. Результатом выполнения задания является отдельный файл.

Напишите программу для решения следующей задачи.

На зачётной работе по физике ученикам 9 класса было предложено 12 задач. Зачёт можно получить, если правильно решить не менее 8 задач. Сколько учеников получило зачёт? Вычислите среднее количество правильно решённых задач учащимися, получившими зачёт. Гарантируется, что хотя бы один ученик сдал зачёт.

Программа получает на вход количество учеников в классе N (1 ≤ N ≤ 30), затем для каждого ученика вводится количество правильно решённых задач.

Пример работы программы:

Входные данныеВыходные данные
4
3
9
10
6
2
9.5


Пояснение:
Решением является программа, записанная на любом языке программирования. Пример верного решения, записанного на языке Python:

number_of_students = int(input())

students_results = []
count_students = 0

for __ in range(number_of_students):
    number_of_correct_tasks = int(input())
    if number_of_correct_tasks >= 8:
        count_students += 1
        students_results.append(number_of_correct_tasks)
average = sum(students_results) / len(students_results)

print(count_students)
print(average)


Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке


Тест с похожими заданиями