Задание №3905. Задание выполняется на компьютере. Результатом выполнения задания является отдельный файл. Напишите программу, которая в последовательности натуральных чисел определяет минимальное число, кратное 3. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 3. Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число – минимальное число, кратное 3. Пример работы программы: Входные данныеВыходные данные3 21 12 3112


Задание №3905.
Создание программы. ОГЭ по информатике

Задание выполняется на компьютере. Результатом выполнения задания является отдельный файл.

Напишите программу, которая в последовательности натуральных чисел определяет минимальное число, кратное 3. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 3.

Количество чисел не превышает 1000. Введённые числа не превышают 30 000.

Программа должна вывести одно число – минимальное число, кратное 3.

Пример работы программы:

Входные данныеВыходные данные
3
21
12
31
12


Пояснение:
Решением является программа, записанная на любом языке программирования. Пример верного решения, записанного на языке Python:

total_numbers = int(input())

min_number = 9999999

for __ in range(total_numbers):
    number = int(input())
    if number % 3 == 0:
        if number < min_number:
            min_number = number
print(min_number)


Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке


Тест с похожими заданиями