Задание №3907. Задание выполняется на компьютере. Результатом выполнения задания является отдельный файл. Напишите программу, которая в последовательности натуральных чисел находит среднее арифметическое трёхзначных чисел или сообщает, что таких чисел нет (выводит NO). Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 undefined признак окончания ввода, не входит в последовательность). Количество чисел не превышает 20. Введённые числа не превышают 1500. Программа должна вывести среднее арифметическое трёхзначных чисел или вывести «NO», если таких чисел нет. Пример работы программы: Входные данныеВыходные данные10 120 125 0122.511 1 0NO


Задание №3907.
Создание программы. ОГЭ по информатике

Задание выполняется на компьютере. Результатом выполнения задания является отдельный файл.

Напишите программу, которая в последовательности натуральных чисел находит среднее арифметическое трёхзначных чисел или сообщает, что таких чисел нет (выводит NO). Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 undefined признак окончания ввода, не входит в последовательность).

Количество чисел не превышает 20. Введённые числа не превышают 1500.

Программа должна вывести среднее арифметическое трёхзначных чисел или вывести «NO», если таких чисел нет.

Пример работы программы:

Входные данныеВыходные данные
10
120
125
0
122.5
11
1
0
NO


Пояснение:
Решением является программа, записанная на любом языке программирования. Пример верного решения, записанного на языке Python:

three_digit_numbers = []

number = int(input())

while number != 0:
    if len(str(number)) == 3:
        three_digit_numbers.append(number)
    number = int(input())

if three_digit_numbers:
    print(sum(three_digit_numbers) / len(three_digit_numbers))
else:
    print('NO')


Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке


Тест с похожими заданиями