Задание №3908. Задание выполняется на компьютере. Результатом выполнения задания является отдельный файл. Напишите программу, которая в последовательности натуральных чисел находит среднее арифметическое чисел, кратных 4, или сообщает, что таких чисел нет (выводит NO). Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 undefined признак окончания ввода, не входит в последовательность). Количество чисел не превышает 100. Введённые числа не превышают 300. Программа должна вывести среднее арифметическое чисел, кратных 4 или вывести «NO», если таких чисел нет. Пример работы программы: Входные данныеВыходные данные8 120 64 16 052.0111 1 0NO

Задание №3908.
Создание программы. ОГЭ по информатике

Задание выполняется на компьютере. Результатом выполнения задания является отдельный файл.

Напишите программу, которая в последовательности натуральных чисел находит среднее арифметическое чисел, кратных 4, или сообщает, что таких чисел нет (выводит NO). Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 undefined признак окончания ввода, не входит в последовательность).

Количество чисел не превышает 100. Введённые числа не превышают 300.

Программа должна вывести среднее арифметическое чисел, кратных 4 или вывести «NO», если таких чисел нет.

Пример работы программы:

Входные данныеВыходные данные
8
120
64
16
0
52.0
111
1
0
NO


Пояснение:
Решением является программа, записанная на любом языке программирования. Пример верного решения, записанного на языке Python:

suitable_numbers = []

number = int(input())

while number != 0:
    if number % 4 == 0:
        suitable_numbers.append(number)
    number = int(input())

if suitable_numbers:
    print(sum(suitable_numbers) / len(suitable_numbers))
else:
    print('NO')


Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке


Тест с похожими заданиями