Задание №3909. Задание выполняется на компьютере. Результатом выполнения задания является отдельный файл. Напишите программу для решения следующей задачи. На соревнованиях по бегу на 5000 метров для выхода в финал необходимо показать время не более 18 минут 30 секунд. Сколько спортсменов по результатам соревнований вышли в финал? Программа получает на вход количество спортсменов, принимавших участие в соревнованиях (1 ≤ N ≤ 100), затем для каждого спортсмена вводится два числа: минуты и секунды – время, показанное на дистанции. Пример работы программы: Входные данныеВыходные данные2 17 15 19 201

Задание №3909.
Создание программы. ОГЭ по информатике

Задание выполняется на компьютере. Результатом выполнения задания является отдельный файл.

Напишите программу для решения следующей задачи.

На соревнованиях по бегу на 5000 метров для выхода в финал необходимо показать время не более 18 минут 30 секунд.

Сколько спортсменов по результатам соревнований вышли в финал?

Программа получает на вход количество спортсменов, принимавших участие в соревнованиях (1 ≤ N ≤ 100), затем для каждого спортсмена вводится два числа: минуты и секунды – время, показанное на дистанции.

Пример работы программы:

Входные данныеВыходные данные
2
17 15
19 20
1


Пояснение:
Решением является программа, записанная на любом языке программирования. Пример верного решения, записанного на языке Python:

number_of_athletes = int(input())

count_athletes = 0

for __ in range(number_of_athletes):
    minutes, seconds = list(map(int, input().split()))
    if (minutes * 60) + seconds <= (18 * 60) + 30:
        count_athletes += 1

print(count_athletes)


Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке


Тест с похожими заданиями