Задание №3922. Задание выполняется на компьютере. Результатом выполнения задания является отдельный файл. Напишите программу, которая в последовательности натуральных чисел определяет минимальное чётное число. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется чётное число. Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число – минимальное чётное число. Пример работы программы: Входные данныеВыходные данные4 3 20 6 86


Задание №3922.
Создание программы. ОГЭ по информатике

Задание выполняется на компьютере. Результатом выполнения задания является отдельный файл.

Напишите программу, которая в последовательности натуральных чисел определяет минимальное чётное число.

Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется чётное число.

Количество чисел не превышает 1000. Введённые числа не превышают 30 000.

Программа должна вывести одно число – минимальное чётное число.

Пример работы программы:

Входные данныеВыходные данные
4
3
20
6
8
6


Пояснение:
Решением является программа, записанная на любом языке программирования. Пример верного решения, записанного на языке Python:

total_numbers = int(input())

min_number = 9999999

for __ in range(total_numbers):
    number = int(input())
    if number % 2 == 0:
        if number < min_number:
            min_number = number
print(min_number)


Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке


Тест с похожими заданиями