Задание №3925. Задание выполняется на компьютере. Результатом выполнения задания является отдельный файл. Напишите программу, которая в последовательности натуральных чисел определяет минимальное число, кратное 9. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 9. Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000. Программа должна вывести одно число: минимальное число, кратное 9. Пример работы программы: Входные данныеВыходные данные3 18 9 319

Задание №3925.
Создание программы. ОГЭ по информатике

Задание выполняется на компьютере. Результатом выполнения задания является отдельный файл.

Напишите программу, которая в последовательности натуральных чисел определяет минимальное число, кратное 9. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 9.

Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000.

Программа должна вывести одно число: минимальное число, кратное 9.

Пример работы программы:

Входные данныеВыходные данные
3
18
9
31
9


Пояснение:
Решением является программа, записанная на любом языке программирования. Пример верного решения, записанного на языке Python:

total_numbers = int(input())

min_number = 9999999

for __ in range(total_numbers):
    number = int(input())
    if number % 9 == 0:
        if number < min_number:
            min_number = number
print(min_number)


Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке


Тест с похожими заданиями