Задание №3926. Задание выполняется на компьютере. Результатом выполнения задания является отдельный файл. Напишите программу, которая в последовательности натуральных чисел определяет максимальное число, оканчивающееся на 9. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, оканчивающееся на 9. Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000. Программа должна вывести одно число: максимальное число, оканчивающееся на 9. Пример работы программы: Входные данныеВыходные данные3 9 19 2319

Задание №3926.
Создание программы. ОГЭ по информатике

Задание выполняется на компьютере. Результатом выполнения задания является отдельный файл.

Напишите программу, которая в последовательности натуральных чисел определяет максимальное число, оканчивающееся на 9. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, оканчивающееся на 9.

Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000.

Программа должна вывести одно число: максимальное число, оканчивающееся на 9.

Пример работы программы:

Входные данныеВыходные данные
3
9
19
23
19


Пояснение:
Решением является программа, записанная на любом языке программирования. Пример верного решения, записанного на языке Python:

total_numbers = int(input())

max_number = 0

for __ in range(total_numbers):
    number = int(input())
    if str(number)[-1] == '9':
        if number > max_number:
            max_number = number
print(max_number)


Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке


Тест с похожими заданиями