Задание №3931. Задание выполняется на компьютере. Результатом выполнения задания является отдельный файл. Напишите программу, которая в последовательности целых чисел вычисляет сумму всех чисел, которые кратны 4 или 9. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). Количество чисел не превышает 20. Введённые числа по модулю не превышают 1500. Программа должна вывести одно число: сумму всех чисел, которые кратны 4 или 9. Пример работы программы: Входные данныеВыходные данные–16 93 90 074


Задание №3931.
Создание программы. ОГЭ по информатике

Задание выполняется на компьютере. Результатом выполнения задания является отдельный файл.

Напишите программу, которая в последовательности целых чисел вычисляет сумму всех чисел, которые кратны 4 или 9. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность).

Количество чисел не превышает 20. Введённые числа по модулю не превышают 1500.

Программа должна вывести одно число: сумму всех чисел, которые кратны 4 или 9.

Пример работы программы:

Входные данныеВыходные данные
–16
93
90
0
74


Пояснение:
Решением является программа, записанная на любом языке программирования. Пример верного решения, записанного на языке Python:

number = int(input())

sum_of_numbers = 0

while number != 0:
    if number % 4 == 0 or number % 9 == 0:
        sum_of_numbers += number
    number = int(input())

print(sum_of_numbers)


Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке


Тест с похожими заданиями