Задание №3944. Задание выполняется на компьютере. Результатом выполнения задания является отдельный файл. Напишите программу для решения следующей задачи. Ученики 4 класса вели дневники наблюдения за погодой и ежедневно записывали дневную температуру. Найдите среднюю температуру за время наблюдения. Если количество дней, когда температура поднималась выше нуля градусов, не менее 5, выведите YES, иначе выведите NO. Программа получает на вход количество дней, в течение которых проводилось наблюдение N (1 ≤ N ≤ 31), затем для каждого дня вводится температура. Пример работы программы: Входные данныеВыходные данные4 –4 12 –2 83.5 NO

Задание №3944.
Создание программы. ОГЭ по информатике

Задание выполняется на компьютере. Результатом выполнения задания является отдельный файл.

Напишите программу для решения следующей задачи.

Ученики 4 класса вели дневники наблюдения за погодой и ежедневно записывали дневную температуру. Найдите среднюю температуру за время наблюдения. Если количество дней, когда температура поднималась выше нуля градусов, не менее 5, выведите YES, иначе выведите NO.

Программа получает на вход количество дней, в течение которых проводилось наблюдение N (1 ≤ N ≤ 31), затем для каждого дня вводится температура.

Пример работы программы:

Входные данныеВыходные данные
4
–4
12
–2
8
3.5
NO


Пояснение:
Решением является программа, записанная на любом языке программирования. Пример верного решения, записанного на языке Python:

number_of_days = int(input())

days_temperature = []

for __ in range(number_of_days):
    temperature = int(input())
    days_temperature.append(temperature)

print(sum(days_temperature) / len(days_temperature))

if len([i for i in days_temperature if i > 0]) >= 5:
    print('YES')
else:
    print('NO')


Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке


Тест с похожими заданиями