Задание №3949. Задание выполняется на компьютере. Результатом выполнения задания является отдельный файл. Напишите программу, которая в последовательности целых чисел находит сумму и количество чисел, кратных 17, или сообщает, что таких чисел нет. На вход программы подаются целые числа, количество введённых чисел неизвестно, последовательность заканчивается числом 0 (0 – признак окончания ввода, не является членом последовательности). Количество чисел не превышает 100. Введённые числа по модулю не превышают 300. Программа должна вывести сумму и количество чисел, кратных 17, или вывести NO, если таких чисел в последовательности нет. Пример работы программы: Входные данныеВыходные данные34 30 17 051 2–16 5 0NO


Задание №3949.
Создание программы. ОГЭ по информатике

Задание выполняется на компьютере. Результатом выполнения задания является отдельный файл.

Напишите программу, которая в последовательности целых чисел находит сумму и количество чисел, кратных 17, или сообщает, что таких чисел нет. На вход программы подаются целые числа, количество введённых чисел неизвестно, последовательность заканчивается числом 0 (0 – признак окончания ввода, не является членом последовательности).

Количество чисел не превышает 100. Введённые числа по модулю не превышают 300.

Программа должна вывести сумму и количество чисел, кратных 17, или вывести NO, если таких чисел в последовательности нет.

Пример работы программы:

Входные данныеВыходные данные
34
30
17
0
51 2
–16
5
0
NO


Пояснение:
Решением является программа, записанная на любом языке программирования. Пример верного решения, записанного на языке Python:

suitable_numbers = []

number = int(input())

while number != 0:
    if number % 17 == 0:
        suitable_numbers.append(number)
    number = int(input())

if suitable_numbers:
    print(sum(suitable_numbers), len(suitable_numbers))
else:
    print('NO')


Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке


Тест с похожими заданиями