Задание №3951. Задание выполняется на компьютере. Результатом выполнения задания является отдельный файл. Напишите программу, которая в последовательности натуральных чисел находит наименьшее число, кратное 3. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не является членом последовательности). Количество чисел не превышает 1000. Введённые числа не превышают 30000. Гарантируется, что в последовательности есть хотя бы одно число, кратное 3. Программа должна вывести наименьшее число, кратное 3. Пример работы программы: Входные данныеВыходные данные45 10 9 09


Задание №3951.
Создание программы. ОГЭ по информатике

Задание выполняется на компьютере. Результатом выполнения задания является отдельный файл.

Напишите программу, которая в последовательности натуральных чисел находит наименьшее число, кратное 3. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не является членом последовательности).

Количество чисел не превышает 1000. Введённые числа не превышают 30000. Гарантируется, что в последовательности есть хотя бы одно число, кратное 3.

Программа должна вывести наименьшее число, кратное 3.

Пример работы программы:

Входные данныеВыходные данные
45
10
9
0
9


Пояснение:
Решением является программа, записанная на любом языке программирования. Пример верного решения, записанного на языке Python:

number = int(input())

min_number = 9999999

while number != 0:
    if number % 3 == 0:
        if number < min_number:
            min_number = number
    number = int(input())
print(min_number)


Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке


Тест с похожими заданиями