Задание №3957. Задание выполняется на компьютере. Результатом выполнения задания является отдельный файл. Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, кратных 3 и оканчивающихся на 8. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 3 и оканчивающееся на 8. Количество чисел не превышает 100. Введённые числа по модулю не превышают 300. Программа должна вывести одно число: сумму чисел, кратных 3 и оканчивающихся на 8. Пример работы программы: Входные данныеВыходные данные3 18 25 4866


Задание №3957.
Создание программы. ОГЭ по информатике

Задание выполняется на компьютере. Результатом выполнения задания является отдельный файл.

Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, кратных 3 и оканчивающихся на 8. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 3 и оканчивающееся на 8.

Количество чисел не превышает 100. Введённые числа по модулю не превышают 300.

Программа должна вывести одно число: сумму чисел, кратных 3 и оканчивающихся на 8.

Пример работы программы:

Входные данныеВыходные данные
3
18
25
48
66


Пояснение:
Решением является программа, записанная на любом языке программирования. Пример верного решения, записанного на языке Python:

total_numbers = int(input())

sum_of_numbers = 0

for __ in range(total_numbers):
    number = int(input())
    if number % 3 == 0 and str(number)[-1] == '8':
        sum_of_numbers += number
print(sum_of_numbers)


Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке


Тест с похожими заданиями