Задание №3958. Задание выполняется на компьютере. Результатом выполнения задания является отдельный файл. Напишите программу, которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 3 и оканчивающихся на 4. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число: сумму всех натуральных чисел, кратных 3 и оканчивающихся на 4. Пример работы программы: Входные данныеВыходные данные16 24 56 22 54 078

Задание №3958.
Создание программы. ОГЭ по информатике

Задание выполняется на компьютере. Результатом выполнения задания является отдельный файл.

Напишите программу, которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 3 и оканчивающихся на 4. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность).

Количество чисел не превышает 1000. Введённые числа не превышают 30 000.

Программа должна вывести одно число: сумму всех натуральных чисел, кратных 3 и оканчивающихся на 4.

Пример работы программы:

Входные данныеВыходные данные
16
24
56
22
54
0
78


Пояснение:
Решением является программа, записанная на любом языке программирования. Пример верного решения, записанного на языке Python:

number = int(input())

sum_of_numbers = 0

while number != 0:
    if number % 3 == 0 and str(number)[-1] == '4':
        sum_of_numbers += number
    number = int(input())
print(sum_of_numbers)


Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке


Тест с похожими заданиями