Задание №3959. Задание выполняется на компьютере. Результатом выполнения задания является отдельный файл. Введите с клавиатуры 5 положительных целых чисел. Вычислите сумму тех из них, которые делятся на 4 и при этом заканчиваются на 6. Программа должна вывести одно число: сумму чисел, кратных 4 и оканчивающихся на 6. Пример работы программы: Входные данныеВыходные данные12 16 36 26 2052

Задание №3959.
Создание программы. ОГЭ по информатике

Задание выполняется на компьютере. Результатом выполнения задания является отдельный файл.

Введите с клавиатуры 5 положительных целых чисел. Вычислите сумму тех из них, которые делятся на 4 и при этом заканчиваются на 6. Программа должна вывести одно число: сумму чисел, кратных 4 и оканчивающихся на 6.

Пример работы программы:

Входные данныеВыходные данные
12
16
36
26
20
52


Пояснение:
Решением является программа, записанная на любом языке программирования. Пример верного решения, записанного на языке Python:

sum_of_numbers = 0

for __ in (range(5)):
    number = int(input())
    if number % 4 == 0 and str(number)[-1] == '6':
        sum_of_numbers += number
print(sum_of_numbers)


Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке


Тест с похожими заданиями