Задание №3964. Задание выполняется на компьютере. Результатом выполнения задания является отдельный файл. Напишите программу, которая в последовательности натуральных чисел определяет количество всех чётных чисел, кратных 7. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число: количество всех чётных чисел, кратных 7. Пример работы программы: Входные данныеВыходные данные35 24 14 22 28 02

Задание №3964.
Создание программы. ОГЭ по информатике

Задание выполняется на компьютере. Результатом выполнения задания является отдельный файл.

Напишите программу, которая в последовательности натуральных чисел определяет количество всех чётных чисел, кратных 7. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа не превышают 30 000.

Программа должна вывести одно число: количество всех чётных чисел, кратных 7.

Пример работы программы:

Входные данныеВыходные данные
35
24
14
22
28
0
2


Пояснение:
Решением является программа, записанная на любом языке программирования. Пример верного решения, записанного на языке Python:

number = int(input())

count_numbers = 0

while number != 0:
    if number % 2 == 0 and number % 7 == 0:
        count_numbers += 1
    number = int(input())
print(count_numbers)


Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке


Тест с похожими заданиями