Задание №3967. Задание выполняется на компьютере. Результатом выполнения задания является отдельный файл. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, меньших 500 и кратных 3. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число: количество натуральных чисел, меньших 500 и кратных 3. Пример работы программы: Входные данныеВыходные данные45 20 600 01

Задание №3967.
Создание программы. ОГЭ по информатике

Задание выполняется на компьютере. Результатом выполнения задания является отдельный файл.

Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, меньших 500 и кратных 3. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность).

Количество чисел не превышает 1000. Введённые числа не превышают 30 000.

Программа должна вывести одно число: количество натуральных чисел, меньших 500 и кратных 3.

Пример работы программы:

Входные данныеВыходные данные
45
20
600
0
1


Пояснение:
Решением является программа, записанная на любом языке программирования. Пример верного решения, записанного на языке Python:

number = int(input())

count_numbers = 0

while number != 0:
    if number < 500 and number % 3 == 0:
        count_numbers += 1
    number = int(input())
print(count_numbers)


Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке


Тест с похожими заданиями