Задание №3968. Задание выполняется на компьютере. Результатом выполнения задания является отдельный файл. Напишите программу, которая в последовательности натуральных чисел определяет сумму двухзначных чисел, кратных 5. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 − признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа не превышают 30000. Программа должна вывести одно число: сумму двухзначных чисел, кратных 5. Пример работы программы: Входные данныеВыходные данные22 45 120 045


Задание №3968.
Создание программы. ОГЭ по информатике

Задание выполняется на компьютере. Результатом выполнения задания является отдельный файл.

Напишите программу, которая в последовательности натуральных чисел определяет сумму двухзначных чисел, кратных 5. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 − признак окончания ввода, не входит в последовательность).

Количество чисел не превышает 1000. Введённые числа не превышают 30000.

Программа должна вывести одно число: сумму двухзначных чисел, кратных 5.

Пример работы программы:

Входные данныеВыходные данные
22
45
120
0
45


Пояснение:
Решением является программа, записанная на любом языке программирования. Пример верного решения, записанного на языке Python:

number = int(input())

sum_of_numbers = 0

while number != 0:
    if len(str(number)) == 2 and number % 5 == 0:
        sum_of_numbers += number
    number = int(input())

print(sum_of_numbers)


Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке


Тест с похожими заданиями