Задание №4229.
Исполнение алгоритмов. ОГЭ по информатике
Ниже приведена программа, записанная на пяти языках программирования.
Алгоритмический язык | Паскаль |
алг нач цел s, t, A ввод s ввод t ввод A если s > A или t > 12 то вывод "YES" иначе вывод "NO" все кон | var s, t, A: integer; begin readln(s); readln(t); readln(A); if (s > A) or (t > 12) then writeln("YES") else writeln("NO") end. |
Бейсик | Python |
DIM s, t, A AS INTEGER INPUT s INPUT t INPUT A IF s > A OR t > 12 THEN PRINT "YES" ELSE PRINT "NO" ENDIF | s = int(input()) t = int(input()) A = int(input()) if (s > A) or (t > 12): print("YES") else: print("NO") |
C++ |
#include <iostream> using namespace std; int main() { int s, t, A; cin >> s; cin >> t; cin >> A; if (s > A || t > 12) cout << "YES" << endl; else cout << "NO" << endl; return 0; } |
Было проведено 9 запусков программы, при которых в качестве значений переменных s и t вводились следующие пары чисел:
(13, 2); (11, 12); (–12, 12); (2, –2); (–10, –10); (6, –5); (2, 8); (9, 10); (1, 13).
Укажите наименьшее целое значение параметра А, при котором для указанных входных данных программа напечатает «NO» шесть раз.
Пояснение:
Высказывание, написанное в программе, можно переписать в виде:
(s > A) ИЛИ (t > 12).Чтобы приведенное выше высказывание было ложным, ложными должны быть оба исходных высказывания, так как при дизъюнкции (ИЛИ) новое высказывание является ложным тогда и только тогда, когда оба исходных высказывания ложны.
Заметим, что высказывание (
t > 12) будет истинным при
t ≥ 13. Следовательно, при паре переменных
s и
t, равной (1, 13), высказывание
(s > A) ИЛИ (t > 12)будет истинным вне зависимости от значения параметра
A. Поэтому далее мы не будем рассматривать пару чисел (1, 13).
Теперь наша задача сводится к поиску наименьшего целого значения параметра
А, при котором высказывание (
s >
A) будет ложным шесть раз при
s = 13; 11; –12; 2; –10; 6; 2; 9.
Подставим вместо
А число 9: (
s > 9).
Тогда при
s = 13 получим: (13 > 9) — истина; при
s = 11 получим: (11 > 9) — истина; при
s = –12 получим: (–12 > 9) —
ложь; при
s = 2 получим: (2 > 9) —
ложь; при
s = –10 получим: (–10 > 9) —
ложь; при
s = 6 получим: (6 > 9) —
ложь; при
s = 2 получим: (2 > 9) —
ложь; при
s = 9 получим: (9 > 9) —
ложь.
Отметим, что при
А = 10 высказывание (
s >
A) будет также ложным шесть раз, однако по условию задания нам необходимо подобрать
наименьшее целое значение параметра
А.
Таким образом,
9 — наименьшее целое значение параметра А, при котором для указанных входных данных программа напечатает «NO» шесть раз.
Показать ответ
9
Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке
Тест с похожими заданиями