Задание №4289.
Исполнение алгоритмов. ОГЭ по информатике
Ниже приведена программа, записанная на пяти языках программирования.
Алгоритмический язык | Паскаль |
алг нач цел s, t, A ввод s ввод t ввод A если s > A или t > 12 то вывод "YES" иначе вывод "NO" все кон | var s, t, A: integer; begin readln(s); readln(t); readln(A); if (s > A) or (t > 12) then writeln("YES") else writeln("NO") end. |
Бейсик | Python |
DIM s, t, A AS INTEGER INPUT s INPUT t INPUT A IF s > A OR t > 12 THEN PRINT "YES" ELSE PRINT "NO" ENDIF | s = int(input()) t = int(input()) A = int(input()) if (s > A) or (t > 12): print("YES") else: print("NO") |
C++ |
#include <iostream> using namespace std; int main() { int s, t, A; cin >> s; cin >> t; cin >> A; if (s > A || t > 12) cout << "YES" << endl; else cout << "NO" << endl; return 0; } |
Было проведено 9 запусков программы, при которых в качестве значений переменных s и t вводились следующие пары чисел:
(13, 2); (11, 12); (–12, 12); (2, –2); (–10, –10); (6, –5); (2, 8); (9, 10); (1, 13).
Укажите наибольшее целое значение параметра А, при котором для указанных входных данных программа напечатает «YES» пять раз.
Пояснение:
Высказывание, написанное в программе, можно переписать в виде:
(s > A) ИЛИ (t > 12).Чтобы приведенное выше высказывание было истинным, истинным должно быть хотя бы одно из исходных высказываний, так как при дизъюнкции (ИЛИ) новое высказывание является ложным тогда и только тогда, когда оба исходных высказывания ложны.
Заметим, что высказывание (
t > 12) будет истинным при
t ≥ 13. Следовательно, при паре переменных
s и
t, равной (1, 13), высказывание
(s > A) ИЛИ (t > 12)будет истинным вне зависимости от значения параметра
A.
Поэтому наша задача сводится к поиску наибольшего целого значения параметра
А, при котором высказывание (
s >
A) будет истинным четыре раза при значениях переменной
s из оставшихся восьми пар чисел (при
s = 13; 11; –12; 2; –10; 6; 2; 9).
Подставим вместо
А число 5: (
s > 5).
Тогда при
s = 13 получим: (13 > 5) —
истина; при
s = 11 получим: (11 > 5) —
истина; при
s = –12 получим: (–12 > 5) — ложь; при
s = 2 получим: (2 > 5) — ложь; при
s = –10 получим: (–10 > 5) — ложь; при
s = 6 получим: (6 > 5) —
истина; при
s = 2 получим: (2 > 5) — ложь; при
s = 9 получим: (9 > 5) —
истина.
Отметим, что при
А = 2; 3; 4 высказывание (
s >
A) будет также истинным четыре раза, однако по условию задания нам необходимо подобрать
наибольшее целое значение параметра
А.
Таким образом,
5 — наибольшее целое значение параметра А, при котором для указанных входных данных программа напечатает «YES» пять раз.
Показать ответ
5
Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке
Тест с похожими заданиями