Задание №4299.
Исполнение алгоритмов. ОГЭ по информатике
Ниже приведена программа, записанная на пяти языках программирования.
| Алгоритмический язык | Паскаль |
алг нач цел s, t, A ввод s ввод t ввод A если s > А или t > 11 то вывод "YES" иначе вывод "NO" все кон | var s, t, A: integer; begin readln(s); readln(t); readln(A); if (s > А) or (t > 11) then writeln("YES") else writeln("NO") end. |
| Бейсик | Python |
DIM s, t, A AS INTEGER INPUT s INPUT t INPUT A IF s > А OR t > 11 THEN PRINT "YES" ELSE PRINT "NO" ENDIF | s = int(input()) t = int(input()) A = int(input()) if (s > А) or (t > 11): print("YES") else: print("NO") |
| C++ |
#include <iostream> using namespace std; int main(){ int s, t, A; cin >> s; cin >> t; cin >> A; if (s > А || t > 11) cout << "YES" << endl; else cout << "NO" << endl; return 0; } |
Было проведено 9 запусков программы, при которых в качестве значений переменных s и t вводились следующие пары чисел:
(–9, 11); (2, 7); (5, 12); (2, –2); (7, –9); (12, 6); (9, –1); (7, 11); (11, –5).
Укажите наибольшее целое значение параметра А, при котором для указанных входных данных программа напечатает «NO» пять раз.
Пояснение:
Высказывание, написанное в программе, можно переписать в виде:
(s > A) ИЛИ (t > 11).Чтобы приведенное выше высказывание было ложным, ложными должны быть оба исходных высказывания, так как при дизъюнкции (ИЛИ) новое высказывание является ложным тогда и только тогда, когда оба исходных высказывания ложны.
Заметим, что высказывание (
t > 11) будет истинным при
t ≥ 12. Следовательно, при паре переменных
s и
t, равной (5, 12), высказывание
(s > A) ИЛИ (t > 11)будет истинным вне зависимости от значения параметра
A. Поэтому далее мы не будем рассматривать пару чисел (5, 12).
Теперь наша задача сводится к поиску наибольшего целого значения параметра
А, при котором высказывание (
s >
A) будет ложным пять раз при
s = –9; 2; 2; 7; 12; 9; 7; 11.
Подставим вместо
А число 8: (
s > 8).
Тогда при
s = –9 получим: (–9 > 8) —
ложь; при
s = 2 получим: (2 > 8) —
ложь; при
s = 2 получим: (2 > 8) —
ложь; при
s = 7 получим: (7 > 8) —
ложь; при
s = 12 получим: (12 > 8) — истина; при
s = 9 получим: (9 > 8) — истина; при
s = 7 получим: (7 > 8) —
ложь; при
s = 11 получим: (11 > 8) — истина.
Отметим, что при
А = 7 высказывание (
t >
A) будет также ложным пять раз, однако по условию задания нам необходимо подобрать
наибольшее целое значение параметра
А.
Таким образом,
8 — наибольшее целое значение параметра А, при котором для указанных входных данных программа напечатает «NO» пять раз.
Показать ответ
8
Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке
Тест с похожими заданиями