Задание №4321. Задание выполняется на компьютере. Архив, необходимый для выполнения задания: ссылка для скачивания. Сколько файлов с расширением .txt содержится в подкаталогах каталога Проза? В ответе укажите только число.


Задание №4321.
Определение количества и размера файлов, отобранных по некоторому условию. ОГЭ по информатике

Задание выполняется на компьютере.

Архив, необходимый для выполнения задания: ссылка для скачивания.

Сколько файлов с расширением .txt содержится в подкаталогах каталога Проза? В ответе укажите только число.

Пояснение:
1 файл с расширением .txt содержится в подкаталогах каталога Проза.

Python-код для перебора файлов в каталоге:

import os

rootdir = r'' # Переменная для указания пути к каталогу; например, r'C:\Users\DEMO-12'

for subdir, dirs, files in os.walk(rootdir):
    for file in files:
        file_path = subdir + os.sep + file
        file_size = os.path.getsize(file_path) # размер файла в байтах
        print(f"{file_path} (размер: {file_size} байт)")


Показать ответ

Источник: Демонстрационная версия ОГЭ–2023
Сообщить об ошибке


Тест с похожими заданиями