Задание №4324. Задание выполняется на компьютере. Результатом выполнения задания является отдельный файл. Выберите ОДНО из предложенных ниже заданий: 15.1 или 15.2. 15.1 Исполнитель Робот умеет перемещаться по лабиринту, начерченному на плоскости, разбитой на клетки. Между соседними (по сторонам) клетками может стоять стена, через которую Робот пройти не может. У Робота есть девять команд. Пять команд – это команды-приказы. Четыре из них управляют перемещениями Робота: вверх вниз влево вправо При выполнении любой из этих команд Робот перемещается на одну клетку соответственно: вверх ↑, вниз ↓, влево ←, вправо →. Если Робот получит команду передвижения сквозь стену, то он разрушится. Также у Робота есть команда закрасить, при которой закрашивается клетка, в которой Робот находится в настоящий момент. Ещё четыре команды – это команды проверки условий. Эти команды проверяют, свободен ли путь для Робота в каждом из четырёх возможных направлений: сверху свободно снизу свободно слева свободно справа свободно Эти команды можно использовать вместе с условием «eсли», имеющим следующий вид: если условие то последовательность команд все Здесь условие – одна из команд проверки условия. Последовательность команд – это одна или несколько любых команд-приказов. Например, для передвижения на одну клетку вправо, если справа нет стенки и закрашивания клетки, можно использовать такой алгоритм: если справа свободно то   вправо   закрасить все В одном условии можно использовать несколько команд проверки условий, применяя логические связки и, или, не, например: если (справа свободно) и (не снизу свободно) то   вправо все Для повторения последовательности команд можно использовать цикл «пока», имеющий следующий вид: нц пока условие   последовательность команд кц Например, для движения вправо, пока это возможно, можно использовать следующий алгоритм: нц пока справа свободно   вправо кц Выполните задание. На бесконечном поле есть горизонтальная и вертикальная стены. Правый конец горизонтальной стены соединён с верхним концом вертикальной стены. Длины стен неизвестны. В каждой стене есть ровно один проход, точное место прохода и его ширина неизвестны. Робот находится в клетке, расположенной непосредственно под горизонтальной стеной у её левого конца. На рисунке указан один из возможных способов расположения стен и Робота (Робот обозначен буквой «Р»). Напишите для Робота алгоритм, закрашивающий все клетки, расположенные непосредственно ниже горизонтальной стены и левее вертикальной стены, кроме клетки, в которой находится Робот перед выполнением программы. Проходы должны остаться незакрашенными. Робот должен закрасить только клетки, удовлетворяющие данному условию. Например, для приведённого выше рисунка Робот должен закрасить следующие клетки (см. рисунок). При исполнении алгоритма Робот не должен разрушиться, выполнение алгоритма должно завершиться. Конечное расположение Робота может быть произвольным. Алгоритм должен решать задачу для любого допустимого расположения стен и любого расположения и размера проходов внутри стен. Алгоритм может быть выполнен в среде формального исполнителя или записан в текстовом редакторе. Сохраните алгоритм в файле. Название файла и каталог для сохранения Вам сообщат организаторы экзамена. 15.2 Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4, но не кратных 7. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4 и не кратное 7. Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число: количество чисел, кратных 4, но не кратных 7. Пример работы программы: Входные данныеВыходные данные4 16 28 26 242

Задание №4324.
Создание программы для заданного исполнителя или на универсальном языке программирования. ОГЭ по информатике

Задание выполняется на компьютере. Результатом выполнения задания является отдельный файл.

Выберите ОДНО из предложенных ниже заданий: 15.1 или 15.2.

15.1 Исполнитель Робот умеет перемещаться по лабиринту, начерченному на плоскости, разбитой на клетки. Между соседними (по сторонам) клетками может стоять стена, через которую Робот пройти не может.

У Робота есть девять команд. Пять команд – это команды-приказы. Четыре из них управляют перемещениями Робота:

вверх вниз влево вправо

При выполнении любой из этих команд Робот перемещается на одну клетку соответственно: вверх ↑, вниз ↓, влево ←, вправо →. Если Робот получит команду передвижения сквозь стену, то он разрушится.

Также у Робота есть команда закрасить, при которой закрашивается клетка, в которой Робот находится в настоящий момент.

Ещё четыре команды – это команды проверки условий. Эти команды проверяют, свободен ли путь для Робота в каждом из четырёх возможных направлений:

сверху свободно

снизу свободно

слева свободно

справа свободно

Эти команды можно использовать вместе с условием «eсли», имеющим следующий вид:

если условие то

последовательность команд

все

Здесь условие – одна из команд проверки условия.

Последовательность команд – это одна или несколько любых команд-приказов.

Например, для передвижения на одну клетку вправо, если справа нет стенки и закрашивания клетки, можно использовать такой алгоритм:

если справа свободно то

  вправо

  закрасить

все

В одном условии можно использовать несколько команд проверки условий, применяя логические связки и, или, не, например:

если (справа свободно) и (не снизу свободно) то

  вправо

все

Для повторения последовательности команд можно использовать цикл «пока», имеющий следующий вид:

нц пока условие

  последовательность команд

кц

Например, для движения вправо, пока это возможно, можно использовать следующий алгоритм:

нц пока справа свободно

  вправо

кц

Выполните задание.

На бесконечном поле есть горизонтальная и вертикальная стены. Правый конец горизонтальной стены соединён с верхним концом вертикальной стены. Длины стен неизвестны. В каждой стене есть ровно один проход, точное место прохода и его ширина неизвестны. Робот находится в клетке, расположенной непосредственно под горизонтальной стеной у её левого конца.

На рисунке указан один из возможных способов расположения стен и Робота (Робот обозначен буквой «Р»).


Напишите для Робота алгоритм, закрашивающий все клетки, расположенные непосредственно ниже горизонтальной стены и левее вертикальной стены, кроме клетки, в которой находится Робот перед выполнением программы. Проходы должны остаться незакрашенными. Робот должен закрасить только клетки, удовлетворяющие данному условию. Например, для приведённого выше рисунка Робот должен закрасить следующие клетки (см. рисунок).


При исполнении алгоритма Робот не должен разрушиться, выполнение алгоритма должно завершиться. Конечное расположение Робота может быть произвольным.

Алгоритм должен решать задачу для любого допустимого расположения стен и любого расположения и размера проходов внутри стен.

Алгоритм может быть выполнен в среде формального исполнителя или записан в текстовом редакторе.

Сохраните алгоритм в файле. Название файла и каталог для сохранения Вам сообщат организаторы экзамена.

15.2 Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4, но не кратных 7. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4 и не кратное 7.

Количество чисел не превышает 1000. Введённые числа не превышают 30 000.

Программа должна вывести одно число: количество чисел, кратных 4, но не кратных 7.

Пример работы программы:

Входные данныеВыходные данные
4
16
28
26
24
2


Пояснение:
15.1 Команды исполнителя будем записывать полужирным шрифтом, а комментарии, поясняющие алгоритм и не являющиеся его частью, – курсивом. Начало комментария будем обозначать символом «|».

|Пропускаем клетку, в которой стоит Робот.

вправо

|Двигаемся вправо, пока не дойдём до прохода в горизонтальной стене.

|Закрашиваем пройденные клетки.

нц пока не сверху свободно
  закрасить
  вправо
кц


|Двигаемся дальше до горизонтальной стены.

нц пока сверху свободно
  вправо
кц


|Двигаемся вправо, пока не дойдём до вертикальной стены.

|Закрашиваем пройденные клетки.

нц пока справа свободно
  закрасить
  вправо
кц


|Двигаемся вниз, пока не дойдём до прохода в вертикальной стене.

|Закрашиваем пройденные клетки.

нц пока не справа свободно
  закрасить
  вниз
кц


|Двигаемся дальше до вертикальной стены.

нц пока справа свободно
  вниз
кц


|Двигаемся вниз, до конца вертикальной стены.

|Закрашиваем пройденные клетки.

нц пока не справа свободно
  закрасить
  вниз
кц


Возможны и другие варианты решения.

15.2 Решением является программа, записанная на любом языке программирования. Пример верного решения, записанного на языке Паскаль:

var n, i, a, k: integer;
    begin
    readln(n);
    k := 0;
    for i := 1 to n do
    begin
        readln(a);
        if (a mod 4 = 0) and (a mod 7 <> 0) then k := k + 1;
    end;
    writeln(k)
end.


Возможны и другие варианты решения.

Для проверки правильности работы программы необходимо использовать следующие тесты.

Входные данныеВыходные данные
13
4
7
28
1
24
28
16
4
24
3
35
24
28
4
44
2
3


Источник: Демонстрационная версия ОГЭ–2023
Сообщить об ошибке


Тест с похожими заданиями