Задание №4368. 14.1 Операнды арифметического выражения записаны в системе счисления с основанием 19. 98897x2119 + 2x92319 В записи чисел переменной x обозначена неизвестная цифра из алфавита 19-ричной системы счисления. Определите наибольшее значение x, при котором значение данного арифметического выражения кратно 18. Для найденного x вычислите частное от деления значения арифметического выражения на 18 и укажите его в ответе в десятичной системе счисления. Основание системы счисления указывать не нужно. ИЛИ 14.2 Значение арифметического выражения 3 ∙ 31258 + 2 ∙ 6257 – 4 ∙ 6256 + 3 ∙ 1255 – 2 ∙ 254 – 2024 записали в системе счисления с основанием 25. Сколько значащих нулей содержится в этой записи?

Задание №4368.
Позиционные системы счисления. ЕГЭ по информатике

14.1 Операнды арифметического выражения записаны в системе счисления с основанием 19.

98897x2119 + 2x92319

В записи чисел переменной x обозначена неизвестная цифра из алфавита 19-ричной системы счисления. Определите наибольшее значение x, при котором значение данного арифметического выражения кратно 18.

Для найденного x вычислите частное от деления значения арифметического выражения на 18 и укажите его в ответе в десятичной системе счисления. Основание системы счисления указывать не нужно.

ИЛИ

14.2 Значение арифметического выражения

3 ∙ 31258 + 2 ∙ 6257 – 4 ∙ 6256 + 3 ∙ 1255 – 2 ∙ 254 – 2024

записали в системе счисления с основанием 25. Сколько значащих нулей содержится в этой записи?

Пояснение:
14.1 Решим задание, написав программу на языке программирования Python. Поочередно подставим в приведенное в задании выражение каждую цифру из системы счисления с основанием 19 вместо x, переведем выражение в десятичную систему счисления и проверим, кратно ли оно 18.

all_digits_19 = '0123456789ABCDEFGHI'

for x in all_digits_19:
    f = int(f"98897{x}21", 19) + int(f"2{x}923", 19)
    if f % 18 == 0:
        print(f"x = {x}, {f} / 18 = {f // 18}")

Таким образом, наибольшим значением x, при котором значение данного арифметического выражения кратно 18, это F.

При x = F получаем, что

8442614664 / 18 = 469034148.
.
14.2 Решим задание, написав программу на языке программирования Python.

n = 3 * 3125 ** 8 + 2 * 625 ** 7 - 4 * 625 ** 6 + 3 * 125 ** 5 - 2 * 25 ** 4 - 2024
count = 0
while n:
    if n % 25 == 0:
        count += 1
    n //= 25
print(count)

Таким образом, 9 значащих нулей содержится в этой записи.

Показать ответ

Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке


Тест с похожими заданиями