Задание №4369. Для какого наименьшего целого неотрицательного числа A выражение (x + 2y < A) ∨ (y > x) ∨ (x > 60) тождественно истинно, т. е. принимает значение 1 при любых целых неотрицательных x и y?


Задание №4369.
Основные понятия и законы математической логики. ЕГЭ по информатике

Для какого наименьшего целого неотрицательного числа A выражение

(x + 2y < A) ∨ (y > x) ∨ (x > 60)

тождественно истинно, т. е. принимает значение 1 при любых целых неотрицательных x и y?

Пояснение:
Решим задание, написав программу на языке программирования Python.

for a in range(1000):
    if all((x + 2 * y < a) or (y > x) or (x > 60) for x in range(1000) for y in range(1000)):
        print(a)
        break

Таким образом, 181 — наименьшее целое неотрицательное число A, для которого приведенное в задании выражение тождественно истинно, т. е. принимает значение 1 при любых целых неотрицательных x и y.

Показать ответ

Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке


Тест с похожими заданиями