Задание №4370. Алгоритм вычисления значения функции F(n), где n – натуральное число, задан следующими соотношениями: F(n) = n при n > 2024; F(n) = n ∙ F(n + 1), если n ≤ 2024. Чему равно значение выражения F(2022) / F(2024)?

Задание №4370.
Вычисление рекуррентных выражений. ЕГЭ по информатике

Алгоритм вычисления значения функции F(n), где n – натуральное число, задан следующими соотношениями:

F(n) = n при n > 2024;

F(n) = nF(n + 1), если n ≤ 2024.

Чему равно значение выражения F(2022) / F(2024)?

Пояснение:
Решим задание, написав программу на языке программирования Python.

def f(n):
    if n > 2024:
        return n
    else:
        return n * f(n + 1)
print(f(2022) / f(2024))

Таким образом, значение выражения F(2022) / F(2024) равно 4090506.

Показать ответ

Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке


Тест с похожими заданиями