Задание №4377. Исполнитель преобразует число на экране. У исполнителя есть три команды, которые обозначены латинскими буквами: A. Прибавить 1 B. Умножить на 2 C. Возвести в квадрат Программа для исполнителя – это последовательность команд. Сколько существует программ, для которых при исходном числе 2 результатом является число 20, при этом траектория вычислений не содержит числа 11? Траектория вычислений программы – это последовательность результатов выполнения всех команд программы. Например, для программы CBA при исходном числе 4 траектория будет состоять из чисел 16, 32, 33.

Задание №4377.
Анализ хода исполнения алгоритма. ЕГЭ по информатике

Исполнитель преобразует число на экране.

У исполнителя есть три команды, которые обозначены латинскими буквами:

A. Прибавить 1

B. Умножить на 2

C. Возвести в квадрат

Программа для исполнителя – это последовательность команд.

Сколько существует программ, для которых при исходном числе 2 результатом является число 20, при этом траектория вычислений не содержит числа 11?

Траектория вычислений программы – это последовательность результатов выполнения всех команд программы. Например, для программы CBA при исходном числе 4 траектория будет состоять из чисел 16, 32, 33.

Пояснение:
Решим задание, написав программу на языке программирования Python.

def f(x, y):
    if x > y or x == 11: return 0
    if x == y: return 1
    return f(x + 1, y) + f(x * 2, y) + f(x ** 2, y)

print(f(2, 20))

Таким образом, существует 37 программ, для которых при исходном числе 2 результатом является число 20, при этом траектория вычислений не содержит числа 11.

Показать ответ

Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке


Тест с похожими заданиями