Задание №4379. Назовём маской числа последовательность цифр, в которой также могут встречаться следующие символы: – символ «?» означает ровно одну произвольную цифру; – символ «*» означает любую последовательность цифр произвольной длины; в том числе «*» может задавать и пустую последовательность. Например, маске 123*4?5 соответствуют числа 123405 и 12300405. Среди натуральных чисел, меньших 1010, найдите все числа, соответствующие маске 1?2157*4, делящиеся на 2024 без остатка. В ответе сначала запишите все найденные числа в порядке возрастания, а затем – соответствующие им результаты деления этих чисел на 2024.

Задание №4379.
Создание собственной программы. ЕГЭ по информатике

Назовём маской числа последовательность цифр, в которой также могут встречаться следующие символы:

– символ «?» означает ровно одну произвольную цифру;

– символ «*» означает любую последовательность цифр произвольной длины; в том числе «*» может задавать и пустую последовательность.

Например, маске 123*4?5 соответствуют числа 123405 и 12300405.

Среди натуральных чисел, меньших 1010, найдите все числа, соответствующие маске 1?2157*4, делящиеся на 2024 без остатка.

В ответе сначала запишите все найденные числа в порядке возрастания, а затем – соответствующие им результаты деления этих чисел на 2024.

Пояснение:
Решим задание, написав программу на языке программирования Python.

for x in range(2024, 10 ** 10 + 1, 2024):
    s = str(x)
    if s[0] == '1' and s[2:6] == '2157' and s[-1] == '4':
        print(s, int(s) // 2024)

Таким образом, получаем

Найденные
числа

Результаты
их деления
на 2024

14215766470236
1021575544504731
1121571264554136
1221577104603546
1321572824652951
1421578664702361
1521574384751766
1621570104801171
1721575944850581
1821571664899986
1921577504949396


Показать ответ

Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке


Тест с похожими заданиями