Задание №4383. Миша заполнял таблицу истинности логической функции F (x ∨ ¬y) ∧ ¬(y ≡ z) ∧ ¬w, но успел заполнить лишь фрагмент из трёх различных её строк, даже не указав, какому столбцу таблицы соответствует каждая из переменных w, x, y, z.     F11  1 10011 101 Определите, какому столбцу таблицы соответствует каждая из переменных w, x, y, z. В ответе напишите буквы w, x, y, z в том порядке, в котором идут соответствующие им столбцы (сначала буква, соответствующая первому столбцу; затем буква, соответствующая второму столбцу, и т.д.). Буквы в ответе пишите подряд, никаких разделителей между буквами ставить не нужно. Пример. Функция F задана выражением ¬x ∨ y, зависящим от двух переменных, а фрагмент таблицы имеет следующий вид.   F010 В этом случае первому столбцу соответствует переменная y, а второму столбцу – переменная x. В ответе следует написать: yx.

Задание №4383.
Таблицы истинности и логические схемы. ЕГЭ по информатике

Миша заполнял таблицу истинности логической функции F

(x ∨ ¬y) ∧ ¬(y ≡ z) ∧ ¬w,

но успел заполнить лишь фрагмент из трёх различных её строк, даже не указав, какому столбцу таблицы соответствует каждая из переменных w, x, y, z.

    F
11  1
 1001
1 101

Определите, какому столбцу таблицы соответствует каждая из переменных w, x, y, z.

В ответе напишите буквы w, x, y, z в том порядке, в котором идут соответствующие им столбцы (сначала буква, соответствующая первому столбцу; затем буква, соответствующая второму столбцу, и т.д.). Буквы в ответе пишите подряд, никаких разделителей между буквами ставить не нужно.

Пример. Функция F задана выражением ¬x ∨ y, зависящим от двух переменных, а фрагмент таблицы имеет следующий вид.

  F
010

В этом случае первому столбцу соответствует переменная y, а второму столбцу – переменная x. В ответе следует написать: yx.

Пояснение:
Составим неполную таблицу истинности для приведенной в задании функции, используя язык программирования Python. Так как в таблице, приведенной в задании, значения F во всех случаях равны 1, ограничимся лишь поиском тех значений переменных w, x, y и z, при которых функция F является истинной.

print('w x y z')
for w in range(2):
    for x in range(2):
        for y in range(2):
            for z in range(2):
                if (x or not y) and not(y == z) and not w:
                    print(w, x, y, z)

Исполнив приведенный выше код, получаем:

w x  y zF
00011
01011
01101

Теперь, зная значения всех переменных, при которых функция F является истинной, мы можем заполнить пропуски в приведенной в задании таблице:

xzywF
11001
01001
10101

Таким образом, столбцам таблицы, начиная с первого, соответствуют переменные x, z, y, w.

Показать ответ

Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке


Тест с похожими заданиями