Задание №4389. Все четырёхбуквенные слова, составленные из букв А, Б, З, И, записаны в алфавитном порядке и пронумерованы начиная с 1. Ниже приведено начало списка. 1. АААА 2. АААБ 3. АААЗ 4. АААИ 5. ААБА … Под каким номером стоит слово ИЗБА?

Задание №4389.
Измерение количества информации. ЕГЭ по информатике

Все четырёхбуквенные слова, составленные из букв А, Б, З, И, записаны в алфавитном порядке и пронумерованы начиная с 1.

Ниже приведено начало списка.
1. АААА
2. АААБ
3. АААЗ
4. АААИ
5. ААБА


Под каким номером стоит слово ИЗБА?

Пояснение:
Найдем, под каким номером стоит слово ИЗБА, написав программу на языке программирования Python.

from itertools import product

collection = product('АБЗИ', repeat=4) # создаем коллекцию картежей, состоящую из 256 элементов

list_collection = []

for line in collection:
    line = ''.join(line) # переводим картеж в строку
    list_collection.append(line)

print(sorted(list_collection).index("ИЗБА")+1) # прибавляем 1, так как нумерация списка начинается с 0

Таким образом, слово ИЗБА стоит под номером 229.

Показать ответ

Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке


Тест с похожими заданиями