Задание №4390. Файл, необходимый для выполнения задания: ссылка для скачивания. Откройте файл электронной таблицы, содержащей в каждой строке пять натуральных чисел. Определите количество строк таблицы, содержащих числа, для которых выполнены оба условия: – в строке все числа различны; – удвоенная сумма максимального и минимального чисел строки не больше суммы оставшихся трёх её чисел. В ответе запишите только число.

Задание №4390.
Обработка числовой информации в электронных таблицах. ЕГЭ по информатике

Файл, необходимый для выполнения задания: ссылка для скачивания.

Откройте файл электронной таблицы, содержащей в каждой строке пять натуральных чисел. Определите количество строк таблицы, содержащих числа, для которых выполнены оба условия:

– в строке все числа различны;

– удвоенная сумма максимального и минимального чисел строки не больше суммы оставшихся трёх её чисел.

В ответе запишите только число.

Пояснение:
Приведем решение данного задания на языке программирования Python. Для этого необходимо скопировать содержимое Excel файла в текстовый документ с расширением .txt.

count = 0

with open('input.txt') as numbers:
    numbers = numbers.read().splitlines()
    for line in numbers:
        line = [int(i) for i in line.split('\t')]
        if len(line) == len(set(line)) and ((min(line) + max(line)) * 2) <= sum(line) - max(line) - min(line):
            count += 1
print(count)

Пример выполнения данного задания в Microsoft Excel: ссылка для скачивания.

Для начала подсчитаем количество повторений каждого из пяти чисел в строке (сколько раз повторяется первое число в строке, сколько раз повторяется второе число в строке и так далее).

Для этого воспользуемся функцией СЧЁТЕСЛИ, подсчитывающей количество ячеек выделенного диапазона, соответствующих заданному условию:

=СЧЁТЕСЛИ($A1:$E1;A1)
=СЧЁТЕСЛИ($A1:$E1;B1)
=СЧЁТЕСЛИ($A1:$E1;C1)
=СЧЁТЕСЛИ($A1:$E1;D1)
=СЧЁТЕСЛИ($A1:$E1;E1)


В первом аргументе функции указываем выбранный диапазон ячеек для подсчета (в нашем случае это значения столбцов A1:E1).

Во втором аргументе функции указываем условие, которое требуется применить (одно из семи чисел в строке).

Затем находим удвоенную сумму максимального и минимального чисел строки, а также сумму трех оставшихся чисел:

=(МИН(A1:E1)+МАКС(A1:E1))*2

=СУММ(A1:E1)-МИН(A1:E1)-МАКС(A1:E1)


Наконец, проверим каждую строку на выполнение двух условий, перечисленных в задании, используя логические функции ЕСЛИ и И:

=ЕСЛИ(И(СУММ(F1:J1)=5;K1<=L1);1;0)

В первом аргументе функции ЕСЛИ указываем логическое выражение, которое необходимо проверить (в нашем случае: "И(СУММ(F1:J1)=5").

Во втором аргументе функции ЕСЛИ указываем значение, которое необходимо вывести, если логическое выражение из первого аргумента истинное, а в третьем — если ложное.

Функция И вернет истину, если все ее аргументы истинны.

В первом аргументе функции И проверяем, что все числа в строке различные (СУММ(F1:J1)=5).

Во втором аргументе функции И проверяем, что удвоенная сумма максимального и минимального чисел строки не больше суммы оставшихся трех чисел (K1<=L1).

Таким образом, 607 строк таблицы соответствуют указанным в задании условиям.

Показать ответ

Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке


Тест с похожими заданиями