Задание №4395. Операнды арифметического выражения записаны в системе счисления с основанием 15. 97968x1515 + 7x23315 В записи чисел переменной x обозначена неизвестная цифра из алфавита 15-ричной системы счисления. Определите наименьшее значение x, при котором значение данного арифметического выражения кратно 14. Для найденного значения x вычислите частное от деления значения арифметического выражения на 14 и укажите его в ответе в десятичной системе счисления. Основание системы счисления указывать не нужно.

Задание №4395.
Позиционные системы счисления. ЕГЭ по информатике

Операнды арифметического выражения записаны в системе счисления с основанием 15.

97968x1515 + 7x23315

В записи чисел переменной x обозначена неизвестная цифра из алфавита 15-ричной системы счисления. Определите наименьшее значение x, при котором значение данного арифметического выражения кратно 14. Для найденного значения x вычислите частное от деления значения арифметического выражения на 14 и укажите его в ответе в десятичной системе счисления. Основание системы счисления указывать не нужно.

Пояснение:
Решим задание, написав программу на языке программирования Python. Поочередно подставим в приведенное в задании выражение каждую цифру из системы счисления с основанием 15 вместо x, переведем выражение в десятичную систему счисления и проверим, кратно ли оно 14.

all_digits = '0123456789ABCDE'

for x in all_digits:
    f = int(f"97968{x}15", 15) + int(f"7{x}233", 15)
    if f % 14 == 0:
        print(f"x = {x}, {f} / 14 = {f // 14}")
        break

При x = 5 получаем, что

1625006768 / 14 = 116071912.

Таким образом, частное от деления значения арифметического выражения на 14 при наименьшем значении x равно 116071912.

Показать ответ

Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке


Тест с похожими заданиями