Задание №4396. Для какого наименьшего целого неотрицательного числа А логическое выражение (x ≥ 12) ∨ (3x < y) ∨ (xy < A) тождественно истинно (т.е. принимает значение 1) при любых целых неотрицательных x и y?


Задание №4396.
Основные понятия и законы математической логики. ЕГЭ по информатике

Для какого наименьшего целого неотрицательного числа А логическое выражение

(x ≥ 12) ∨ (3x < y) ∨ (xy < A)

тождественно истинно (т.е. принимает значение 1) при любых целых неотрицательных x и y?

Пояснение:
Решим задание, написав программу на языке программирования Python.

for a in range(1000):
    if all((x >= 12) or (3 * x < y) or (x * y < a) for x in range(1000) for y in range(1000)):
        print(a)
        break

Таким образом, 364 — наименьшее целое неотрицательное число A, для которого приведенное в задании выражение тождественно истинно, т. е. принимает значение 1 при любых целых неотрицательных x и y.

Показать ответ

Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке


Тест с похожими заданиями