Задание №4397. Алгоритм вычисления значения функции F(n), где n – натуральное число, задан следующими соотношениями: F(n) = n при n ≥ 2025; F(n) = n + F(n + 2), если n < 2025. Чему равно значение выражения F(2022) – F(2023)?


Задание №4397.
Вычисление рекуррентных выражений. ЕГЭ по информатике

Алгоритм вычисления значения функции F(n), где nнатуральное число, задан следующими соотношениями:

F(n) = n при n ≥ 2025;

F(n) = n + F(n + 2), если n < 2025.

Чему равно значение выражения F(2022) – F(2023)?

Пояснение:
Решим задание, написав программу на языке программирования Python.

def f(n):
    if n >= 2025:
        return n
    else:
        return n + f(n + 2)
print(f(2022) - f(2023))

Таким образом, значение выражения F(2022) / F(2023) равно 2024.

Показать ответ

Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке


Тест с похожими заданиями