Задание №4398. Файл, необходимый для выполнения задания: ссылка для скачивания. В файле содержится последовательность натуральных чисел. Элементы последовательности могут принимать целые значения от 1 до 100 000 включительно. Определите количество пар последовательности, в которых только один из элементов является двузначным числом, а сумма элементов пары кратна максимальному двузначному элементу последовательности. В ответе запишите количество найденных пар, затем максимальную из сумм элементов таких пар. В данной задаче под парой подразумевается два идущих подряд элемента последовательности.

Задание №4398.
Составление алгоритма обработки числовой последовательности. ЕГЭ по информатике

Файл, необходимый для выполнения задания: ссылка для скачивания.

В файле содержится последовательность натуральных чисел. Элементы последовательности могут принимать целые значения от 1 до 100 000 включительно. Определите количество пар последовательности, в которых только один из элементов является двузначным числом, а сумма элементов пары кратна максимальному двузначному элементу последовательности.

В ответе запишите количество найденных пар, затем максимальную из сумм элементов таких пар. В данной задаче под парой подразумевается два идущих подряд элемента последовательности.

Пояснение:
Решим задание, написав программу на языке программирования Python.

final = []

with open('17_219.txt') as numbers: # в аргументе необходимо указать путь к файлу

    numbers = numbers.read().splitlines()

    max_two_digit_number = max([int(i) for i in numbers if len(i) == 2])

    for x in range(len(numbers)-1):
        if (len(numbers[x]) != len(numbers[x+1])) and (len(numbers[x]) == 2 or len(numbers[x+1]) == 2) and (sum(map(int, [numbers[x], numbers[x+1]])) % max_two_digit_number == 0):
            final.append((int(numbers[x]), int(numbers[x+1])))

print(len(final), max(sum(i) for i in final))

Таким образом, 16 — количество найденных пар чисел, а 9702 — максимальная из сумм элементов таких пар.

Показать ответ

Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке


Тест с похожими заданиями