Задание №4404. Исполнитель преобразует число на экране. У исполнителя есть три команды, которым присвоены номера: A. Прибавить 1 B. Умножить на 2 C. Умножить на 3 Программа для исполнителя – это последовательность команд. Сколько существует программ, для которых при исходном числе 1 результатом является число 25, при этом траектория вычислений содержит число 11 и не содержит 15? Траектория вычислений программы – это последовательность результатов выполнения всех команд программы. Например, для программы CBA при исходном числе 7 траектория будет состоять из чисел 21, 42, 43.

Задание №4404.
Анализ хода исполнения алгоритма. ЕГЭ по информатике

Исполнитель преобразует число на экране.

У исполнителя есть три команды, которым присвоены номера:

A. Прибавить 1

B. Умножить на 2

C. Умножить на 3

Программа для исполнителя – это последовательность команд.

Сколько существует программ, для которых при исходном числе 1 результатом является число 25, при этом траектория вычислений содержит число 11 и не содержит 15?

Траектория вычислений программы – это последовательность результатов выполнения всех команд программы.

Например, для программы CBA при исходном числе 7 траектория будет состоять из чисел 21, 42, 43.

Пояснение:
Решим задание, написав программу на языке программирования Python.

def f(x, y):
    if x > y or x == 15: return 0
    if x == y: return 1
    return f(x + 1, y) + f(x * 2, y) + f(x * 3, y)

print(f(1, 11) * f(11,25))

Таким образом, существует 46 программ, для которых при исходном числе 1 результатом является число 25, при этом траектория вычислений содержит число 11 и не содержит 15.

Показать ответ

Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке


Тест с похожими заданиями