Задание №4438. На вход алгоритма подаётся натуральное число N. Алгоритм строит по нему новое число R следующим образом. 1. Строится двоичная запись числа N. 2. Далее эта запись обрабатывается по следующему правилу:     а) если число чётное, то к двоичной записи числа слева дописывается 10;     б) если число нечётное, то к двоичной записи числа слева дописывается 1 и справа дописывается 01. Полученная таким образом запись является двоичной записью искомого числа R. Например, для исходного числа 410 = 1002 результатом будет являться число 2010 = 101002, а для исходного числа 510 = 1012 результатом будет являться число 5310 = 1101012. Укажите минимальное число N, после обработки которого с помощью этого алгоритма получается число R, большее, чем 441. В ответе запишите это число в десятичной системе счисления.

Задание №4438.
Формальное исполнение простого алгоритма. ЕГЭ по информатике

На вход алгоритма подаётся натуральное число N. Алгоритм строит по нему новое число R следующим образом.

1. Строится двоичная запись числа N.

2. Далее эта запись обрабатывается по следующему правилу:

    а) если число чётное, то к двоичной записи числа слева дописывается 10;

    б) если число нечётное, то к двоичной записи числа слева дописывается 1 и справа дописывается 01.

Полученная таким образом запись является двоичной записью искомого числа R.

Например, для исходного числа 410 = 1002 результатом будет являться число 2010 = 101002, а для исходного числа 510 = 1012 результатом будет являться число 5310 = 1101012.

Укажите минимальное число N, после обработки которого с помощью этого алгоритма получается число R, большее, чем 441. В ответе запишите это число в десятичной системе счисления.

Пояснение:
Решим задание, написав программу на языке программирования Python.

final_list = []

for n in range(1, 1000):
    binary_n = bin(n)[2:]
    if n % 2 == 0:
        binary_n += '10'
    else:
        binary_n = '1' + binary_n
        binary_n += '01'

    R = int(binary_n, 2)
    if R > 441:
        final_list.append(n)

print(min(final_list))

Таким образом, 47 — минимальное число N, после обработки которого с помощью этого алгоритма получается число R, большее, чем 441.

Показать ответ

Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке


Тест с похожими заданиями