Задание №4451. Все шестибуквенные слова, составленные из букв М, У, Ж, Ч, И, Н, А, записаны в алфавитном порядке и пронумерованы. Вот начало списка: 1. АААААА 2. АААААЖ 3. АААААИ 4. АААААМ 5. АААААН 6. АААААУ 7. АААААЧ …… Определите в этом списке количество слов с чётными номерами, которые не начинаются с буквы Ж и при этом содержат в своей записи не более одной буквы Ч.


Задание №4451.
Измерение количества информации. ЕГЭ по информатике

Все шестибуквенные слова, составленные из букв М, У, Ж, Ч, И, Н, А, записаны в алфавитном порядке и пронумерованы.

Вот начало списка:

1. АААААА

2. АААААЖ

3. АААААИ

4. АААААМ

5. АААААН

6. АААААУ

7. АААААЧ

……

Определите в этом списке количество слов с чётными номерами, которые не начинаются с буквы Ж и при этом содержат в своей записи не более одной буквы Ч.

Пояснение:
Решим задание, написав программу на языке программирования Python.

from itertools import product

collection = sorted(list(''.join(i) for i in product('МУЖЧИНА', repeat=6)))

count = 0

for x in range(len(collection)):
    if (x + 1) % 2 == 0 and collection[x][0] != 'Ж' and collection[x].count('Ч') < 2:
        count += 1
print(count)

Таким образом, в этом списке 39528 слов с чётными номерами, которые не начинаются с буквы Ж и при этом содержат в своей записи не более одной буквы Ч.

Показать ответ

Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке


Тест с похожими заданиями