Задание №4452. Сколько существует десятичных пятизначных чисел, в которых все цифры различны и никакие две чётные или две нечётные цифры не стоят рядом?

Задание №4452.
Измерение количества информации. ЕГЭ по информатике

Сколько существует десятичных пятизначных чисел, в которых все цифры различны и никакие две чётные или две нечётные цифры не стоят рядом?

Пояснение:
Решим задание, написав программу на языке программирования Python.

from itertools import product

collection = sorted(list(''.join(i) for i in product('0123456789', repeat=5)))

count = 0

for line in collection:
    if line[0] != '0' and len(line) == len(set(line)) and all(int(line[i]) % 2 != int(line[i+1]) % 2 for i in range(len(line)-1)):
        count += 1
print(count)

Таким образом, существует 2160 десятичных пятизначных чисел, в которых все цифры различны и никакие две чётные или две нечётные цифры не стоят рядом.

Показать ответ

Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке


Тест с похожими заданиями