Задание №4453. Вася составляет 5-буквенные слова, в которых есть только буквы П, А, У, К, причём в каждом слове есть ровно одна гласная буква и она встречается ровно 1 раз. Каждая из допустимых согласных букв может встречаться в слове любое количество раз или не встречаться совсем. Словом считается любая допустимая последовательность букв, не обязательно осмысленная. Сколько существует таких слов, которые может написать Вася?


Задание №4453.
Измерение количества информации. ЕГЭ по информатике

Вася составляет 5-буквенные слова, в которых есть только буквы П, А, У, К, причём в каждом слове есть ровно одна гласная буква и она встречается ровно 1 раз. Каждая из допустимых согласных букв может встречаться в слове любое количество раз или не встречаться совсем. Словом считается любая допустимая последовательность букв, не обязательно осмысленная. Сколько существует таких слов, которые может написать Вася?

Пояснение:
Решим задание, написав программу на языке программирования Python.

from itertools import product

collection = sorted(list(''.join(i) for i in product('ПАУК', repeat=5)))

count = 0

for line in collection:
    if line.count('А') + line.count('У') == 1:
        count += 1
print(count)

Таким образом, существует 160 слов, которые может написать Вася.

Показать ответ

Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке


Тест с похожими заданиями