Задание №4454. Все 4-буквенные слова, составленные из букв М, А, Р, Т, записаны в алфавитном порядке и пронумерованы, начиная с 1. Ниже приведено начало списка. 1. АААА 2. АААМ 3. АААР 4. АААТ 5. ААМА … Под каким номером в списке идёт первое слово, которое начинается с буквы М?

Задание №4454.
Измерение количества информации. ЕГЭ по информатике

Все 4-буквенные слова, составленные из букв М, А, Р, Т, записаны в алфавитном порядке и пронумерованы, начиная с 1.

Ниже приведено начало списка.
1. АААА
2. АААМ
3. АААР
4. АААТ
5. ААМА


Под каким номером в списке идёт первое слово, которое начинается с буквы М?

Пояснение:
Решим задание, написав программу на языке программирования Python.

from itertools import product

collection = sorted(list(''.join(i) for i in product('МАРТ', repeat=4)))

for x in range(len(collection)):
    if collection[x][0] == 'М':
        print(x+1)
        break

Таким образом, первое слово, которое начинается с буквы М идет в списке под номером 65.

Показать ответ

Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке


Тест с похожими заданиями